Danail  Freshman Member


  • Edit: The problem was resolved today with the Customer service help. Anyway I will post what was the problem (probably), for another customers: I had to change the DNS settings to Public DNS, so in the router and NAS device I set up DNS 1: and DNS 2: Now it works!