Where to download USG100 legacy firmware

Options
I have a remote office where the USG100 has failed.  There is a USG100 kept as a spare but has never been upgraded.  When I try to load the latest firmware onto the spare it is not compatible.   I have read that I need to first install a later version of version 2.2.0 ( C6??) but the old firmware is no longer available for download.  Where can I find it?

Best Answers

  • Zyxel_Kevin
    Zyxel_Kevin Posts: 795  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options
    Hi @stlspartan,
    Welcome to Forum,
    Please kindly check your Private Message. I have sent the Download link for you.
    Kevin
  • Zyxel_Kevin
    Zyxel_Kevin Posts: 795  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited December 2022 Answer ✓
    Options
    Hi @qbert80
    Greeting Forum. Please kindly check your inbox.  I've sent download link to you . 
    And you can find download link here.
    Thank you
    Kevin

All Replies

  • Zyxel_Kevin
    Zyxel_Kevin Posts: 795  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options
    Hi @stlspartan,
    Welcome to Forum,
    Please kindly check your Private Message. I have sent the Download link for you.
    Kevin
  • stlspartan
    Options
    Thanks for the help Kevin!




  • Micke_Usera_AB
    Options
    Could you please send it to me as well?
  • Zyxel_Kevin
    Zyxel_Kevin Posts: 795  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    Hi @Micke_Usera_AB,
    Good day.
    I have sent the link via Private message.Thank you
    Kevin
  • Fred_77
    Fred_77 Posts: 115  Ally Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    Hi
    i recovered an old usg 100 from the basement... with a very old 2.20 fw. 
    I would like to upgrade to 3.30 AQQ7 but it fails with "not compatible". Also AQQ6 and AQQ5 give same result.  I suppose an intermediate release is needed. Someone can send it to me?

    ...
    firmware verifying
    Product model id is not compatible
    The product's model id is 1500
    The ZLD-current image support the following product model id:

    Firmware product model ids are all not compatible to this product
    ...

    Thanks in advance
    Fred
  • Zyxel_Kevin
    Zyxel_Kevin Posts: 795  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    Hi @Fred_77,
    I have sent the Firmware in Private Messages, 
    Please kindly check and install. 
    Thank you
    Kevin

  • qbert80
    Options
    Hy. I have the same problem as Fred_77. My Firmware on the USG100 is 2.20(AQQ.1) and i would like upgrade to 3.30 AQQ7 but it fails with "not compatible"


  • Zyxel_Kevin
    Zyxel_Kevin Posts: 795  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited December 2022 Answer ✓
    Options
    Hi @qbert80
    Greeting Forum. Please kindly check your inbox.  I've sent download link to you . 
    And you can find download link here.
    Thank you
    Kevin

Security Highlight