Legacy firmware for Zywall USG 200

Options
Hi, 
I'm trying to upgrade the firmware from version 2.20(AQU.1) to the latest 3.30(AQU.7) I tried to upgrade directly to the latest version but I get the error that says the firmware is not compatible, I was looking for the intermediate versions but are not available anymore from the site ftp.zyxel.com. 
there is a way to recover it?
Thanks.

Accepted Solution

  • Roby70to
    Roby70to Posts: 8
    Answer ✓
    Options
    Thank you Kevin,
    version 2.20(AQU.2)C0 was finally working, and after I was finally able to install in order the versions
    2.20(AQU.6)C0
    3.00(AQU.0)C0
    3.30(AQU.5)C0
    3.30(AQU.7)C0

«1

All Replies

  • Zyxel_Kevin
    Zyxel_Kevin Posts: 797  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    Hi @Roby70to ,
    Please kindly find the Firmware in Private Messages.
    Kevin
  • Roby70to
    Roby70to Posts: 8
    Options
    HI,
    Thanks for your fast reply!
    I tried to Update the firmware version 3.0 that you sent me, I still get the error
    "errno: -42008 errmsg: Firmware not compatible!" 
    inside the Firmware page, the model on top is "ZyWALL USG 200" so it is right the other info is 
    Boot Module: 1.12
    Current Version: 2.20(AQU.1)
    Released Date: 2010-05-06 11:27:50

    I wonder if I need all the versions also before 3.0.
  • Zyxel_Kevin
    Zyxel_Kevin Posts: 797  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited March 2022
    Options
    Hi @Roby70to ,
    Kindly extract the zip file, and upload the file  "300AQU0C0.bin"

    Thank you.
    Kevin
  • Roby70to
    Roby70to Posts: 8
    Options
    Hi, 
    as you can see in the picture is what I did.

  • Roby70to
    Roby70to Posts: 8
    Options
    I was reading comments about this error and I found another person with the same problem with the model USG 100, he solved it by installing also all the patches in sequence, annoying but effective,
    in my case, I should install in order: 
    2.20(AQU.2)C0
    2.20(AQU.3)C0
    2.20(AQU.4)C0
    2.20(AQU.5)C0
    2.20(AQU.6)C0
    3.00(AQU.0)C0 (the one you sent me)
    3.00(AQU.2)C0
    3.00(AQU.4)C0
    3.30(AQU.1)C0
    3.30(AQU.2)C0
    3.30(AQU.4)C0
    All the files were available on the FTP server Zyxel, It is a pity that the files are no longer available to the community.
  • PeterUK
    PeterUK Posts: 2,856  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited March 2022
    Options
    This what your looking for
    Download Library - ZYWALL USG 200 | ZyXEL

    But if its not updating its likely the boot module verion is too old to allow newer firmware updates 
  • Roby70to
    Roby70to Posts: 8
    Options
    Hi,
    I already tried to download it from the official site but there are only 3 versions
    3.30 AQU.5
    3.30 AQU.6
    3.30 AQU.7
    and all 3 versions gave me "errno: -42008 errmsg: Firmware not compatible!" 
  • PeterUK
    PeterUK Posts: 2,856  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    I would guess you need 2.20(AQU.6)C0 to allow the newer firmware
  • Roby70to
    Roby70to Posts: 8
    Options
    PeterUK said:
    I would guess you need 2.20(AQU.6)C0 to allow the newer firmware
    If anyone has this version to share I can try it 
  • Zyxel_Kevin
    Zyxel_Kevin Posts: 797  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    Hi @Roby70to,
    I have sent the firmware via PM.
    Kindly check.Thank you.
    Kevin

Security Highlight