Port forwarding - wan IP is shown instead of source IP

I set up port forwarding on the ATP200 to receive port 25 to an email server.  Upon receiving an email, the email server shows the atp200 wan ip address instead of the actual source IP.  How can I fix that?

All Replies

  • dabogdan
    dabogdan Posts: 6
    First Comment
    the email server is internal.

  • PeterUK
    PeterUK Posts: 2,704  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited June 2022

    You would of made a routing rule from WAN next hop LAN to SNAT you can remove this rule or set SNAT to none.


  • dabogdan
    dabogdan Posts: 6
    First Comment
    turning off snat appears to drop all traffic
  • PeterUK
    PeterUK Posts: 2,704  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer

    Is your LAN like 192.168.x.x or do you have a WAN subnet for your LAN?

    Does the email server have a gateway IP set?


  • dabogdan
    dabogdan Posts: 6
    First Comment
    added an rule above the default rule for the email server only with no snat.  that works perfectly.  Thanks for the assistance!
  • dabogdan
    dabogdan Posts: 6
    First Comment
    edited June 2022
    Peter.  I have a single public IP which always makes matters interesting.  That is why I'm using port forwarding for the email server.  but yes, it's a 192.168.x.x subnet.  An extra rule for the server and a no snat option fixed it.  now the inbound emails show the source IP address.  thanks again..

Security Highlight