iwpriv(kickmac) - question regarding log

Wookie
Wookie Posts: 23  Freshman Member
Hi community

I have 3x NWA1123-ACv2 which are managed via Nebula. They broadcast the same SSID on both 2.4Ghz and 5Ghz. They work very well so far but recently I noticed that my iPad 8th Gen gets regularly kicked by the same AP (the closest one)

I found this entry in the logs
Station: f4:34:f0:a3:eb:3d has disassoc by iwpriv(kickmac) on Channel: 13, SSID: NWA2.4, 2.4GHz, Signal: -54dBm, Tx/Rx: 1628095104/49025558 Bytes. reason 5

Unfortunately I couldnt find much information on iwpriv nor here in this forum. It seems that it may has something to do with Fast Roaming.

May you have some tips how I can address the problem? The signal strength is very good as the AP is around 3 meters away from the device.



I did configure smart steering as well as assisted roaming and it works very well except with the iPad.


all the best

Andrew






All Replies

  • Zyxel_HsinBo
    Zyxel_HsinBo Posts: 60  Zyxel Employee
    edited June 21

    Thanks for consulting Nebula Support!
    According to the logs that you provided, which were generally recorded with the condition that the station was kicked out by the AP, such as triggering the load balance.

    May we know if the symptom you described impact the usage of your iPad?
    If the symptom not only happens on the iPad 8th, please provide us more information about the devices (ex. mac address, time).
    And please help us to turn on the Zyxel Support Access from the below path.
    We would check your site as soon as possible.

    PATH: Left sidebar ‘Help’ >> Support request >> Invite Zyxel support as administrator >> save


    Thank you.

    Best Regards,

    HsinBo
  • Wookie
    Wookie Posts: 23  Freshman Member
    Hi HsinBo

    many thanks for the quick reply. The site is called Dietikon and I just sent the support request.

    As far as I can see it only happens with the iPad. It impacts the usage as when I am streaming some TV it says that the internet connection has been disabled, then I have to close the app and open it again.

    I would like to understand the mechanism of whats happening and maybe find a solution for it ;)

    all the best

    Andrew
  • Zyxel_HsinBo
    Zyxel_HsinBo Posts: 60  Zyxel Employee
    edited June 24

    Sorry for the late reply.
    We have collected the diagnostics of all of your AP and analyzed them,
    As you mentioned, we observe that logs recorded as “disassoc by iwpriv(kickmac)” related to the feature of fast roaming.
    Could you kindly help us to turn off 11r and observe for a period whether the symptom exists or not?

    And the usage of Smart Steering is to kick out the “sticky old clients”
    (Low aggressiveness of roaming that even there is other better signal AP, it still connects to weak signal one),
    Force them to connect to the AP with a better signal.
    Thus, if there is no sticky client in your environment, you may not need to set up this feature!

    If there is any further assistance that we could help with, please do not hesitate to contact us.
    Have a nice day,
    Thank you.

    Best Regards,

    HsinBo
  • Wookie
    Wookie Posts: 23  Freshman Member
    sorry for the late reply and thanks for the detailed information. I will disable 11r and observe how it behaves, actually I like the feature a lot because it roams very fast (as it should intended to be)

    Smart Steering on the other hand cannot be disabled because I did that already and had issues with sticky clients.
  • Zyxel_HsinBo
    Zyxel_HsinBo Posts: 60  Zyxel Employee

    Hi, @Wookie

     

    Good day.

    Thanks for your sharing!

    We will keep concentrating on fine-tuning the 11r feature for our products,

    If there is another assistance that we could help with, please do not hesitate to contact us!

    Have a nice day,

    Thank you!

     

    Best Regards,

     

    HsinBo

  • Wookie
    Wookie Posts: 23  Freshman Member
    edited July 1
    many thanks. actually there is another issue I have since I recently bought two new smart pedestal fans from Xiaomi.

    As you have access to my site could you please check the logs of the following clients:
    Andreas-ventilator
    Marco-ventilator

    these are the exact same products connected via 2.4Ghz to the same access point. Unfortunately Andreas-Ventilator is producing the below message in Nebula:

    Station: 54:48:e6:d9:85:e7 has deauth by STA Timeout on Channel: 13, SSID: NWA2.4, 2.4GHz, Signal: -45dBm, Tx/Rx: 235129/440512 Bytes. reason 2, Interface:wlan-1-1

    On the other hand Marco-Ventilator is fine. What could cause this issue? I already reset Andreas-ventilator but am still getting the same message (STA Timeout). Both fans are static and have a very good signal strength. I have to turn the fan manually on in order that it reconnects again.

    I also read this thread (https://community.zyxel.com/en/discussion/1777/nebula-deauth-by-sta-timeout-reason-2/p1)  which recommends to disable 802.11k/v and reboot which I did, but it doesnt seem to help.

    many thanks