Slow/capped(?) upload speed behind vpn (router in bridge mode) - PPPoE ISP

2»

All Replies

  • hello mMontana. Yes all set correctly, and as said, download speed is correct. It's the upload speed thats only 1/40 of what it should be. An IT specialist was supposed to check in with me yesterday but we had to postpone that to Monday. Lets see, maybe it's a hardware problem. Thanks so far for your input, which I appreciate greatly!
  • Colleagues, it seems to be unrelated to at least the VPN100.

    We tested yesterday with the Zyxel router and a different VPN and the problem persisted. So, it's either something with the Zyxel router in bridge mode or one or the other underlying service provider (peoplephone, cyberlink, swisscom) is throttling our upspeed, for whatever reason.

    I will post the outcome once this is resolved.
  • mMontana
    mMontana Posts: 1,289  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Might i bet that your connection is not symmetrical?
  • GothmogAgain
    GothmogAgain Posts: 1
    First Comment
    edited April 2023

    Dear all, I promised to post my final findings, once I have them and here we go: The problem was resolved by sacrificing the static ip. The following setup will result in massively reduced upstream (like 30 Mbit instead of up to 1'000):

    • Swisscom fibre
    • Using a subprovider on the Swisscom fibre net
    • Using a static IP and therefore PPPoE instead of IPoE/DHCP
    • Using Windows 10 clients / Windows Server 2019 and older

    To receive your static IP subproviders on the Swisscom fibre net need to authenticate using PPPoE instead of IPoE/DHCP. The moment you authenticate using IPoE/DHCP the problem is resolved, but alas, no more static IP (for VPN purposes etc.).

    Technical details as follows (in German/English):

    ************************************

    Wir hatten vor ein paar Monaten einen ähnlichen Case mit der Kombination "VLAN11/PPP + ZyXEL AX7501 + Langsamer Upload".
    Nach sehr intensivem Troubleshooting sind wir zum Schluss gekommen, dass das Problem an Windows lag;

    [Subprovider 1Gbit/s PPP VLAN 11 via Swisscom XGS - Kunde erreicht auf Win 10 und Win Server 2019 900down / 60up]

    Wir konnten nun bestätigen, dass das Problem auf Windows 11 und Linux Systemen NICHT auftritt.

    Gemäss Blog Entries hat Microsoft den Fix für das Issue scheinbar noch in keinem der Windows 10 Releases implementiert:

    «The improvements did not surface in any mainstream Windows 10 version of which I am aware; however Windows 11 does seem to incorporate substantial changes (at least an improved RFC 8985 (The RACK-TLP Loss Detection Algorithm for TCP) implementation with per-segment tracking)»
    https://gary-nebbett.blogspot.com/2022/01/windows-11-tcpip-congestion-control.html

    Das Problem müsste bei den Server OS ab Windows Server 2022 behoben sein:https://techcommunity.microsoft.com/t5/networking-blog/algorithmic-improvements-boost-tcp-performance-on-the-internet/ba-p/2347061

    Von Microsoft gibt es leider kein offizielles Statement wann bzw. ob es den Fix auch für Windows 10 geben wird.

    Somit ist ein Upgrade auf Windows 11/Server 2022 momentan wohl die einzige Option (oder der Verzicht auf die statische IP).

    ----------------------

    Bzgl. der XGS-PON Problematik und den ~30Mbit/s Upstream gilt noch zu beachten, dass dieses Problem "nur" im Zusammenspiel mit PPPoE Verbindungen auftritt.
    Wir nutzen PPPoE ausschliesslich für Anschlüsse via dem Swisscom Glasfasernetz und nur wenn der Kunde eine statische IP Adresse benötigt.
    In allen andern Szenarien kommt IPoE (DHCP) via VLAN 10 zum Einsatz und hier verhält sich der Windows TCP/IP Stack bei kabelgebundenen Verbindungen ganz normal.
    Dies setzt Swisscom übrigens auch bei den eigenen Anschlüssen ein, daher haben Sie dort bisher noch nie dieses Problem gehabt.

    Die 20-30Mbit/s Upstream gibt es in diesem Problemszenario übrigens unabhängig von der gewählten Bandbreite des Abos, d.h. es ist egal ob Sie ein 100Mbit, 1Gbit oder 10Gbit haben.

Security Highlight