GS1900-8HP, GS1900-10HP, GS1900-24E: firmware 2.70 invalid image signature

Options
nicobar
nicobar Posts: 1

Hi,

I have about a dozen among these swtiches. I have been havin them for a few years, regularly updated to firmware 2.50.

I have no way now to upgrade to 2.70:

  • via ZON, whether I chose to do online upgrade or use the downloades zips, I get "Failed to update firmware { set error } "
  • via web interface, whether I try to upgrade the active or backup image, I get "Invalid Firmware Signature"

I am doing it from a local PC with Windows 10 and windows firewall disabled.

Of course I tried to download the images several times:

GS1900-8HP_2.70(AAHI.5)C0.zip

GS1900-10HP_2.70(AAZI.5)C0.zip

GS1900-24E_2.70(AAHK.5)C0.zip

I also tried to upgrade to 2.60 first, same issue. Any advice?

Thanks!

All Replies

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,632  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @nicobar,

    Welcome to the Zyxel Community!

    This is most likely due to upgrading with the wrong firmware file.

    Please unzip the file and upgraded it with the .bix file.

    Zyxel Melen