I have to upgrade firmware, best practice

RikHead
RikHead Posts: 5
First Comment

Hi to everyobdy,

I have a UGS110 with firmware version 4.31, I need to update it to 4.73 due to the latest zyxell vulnerability notice.
Can I do it from 4.31 to 4.73 or do I need the versions in between first?

Thanks for any help.

Accepted Solution

  • smb_corp_user
    smb_corp_user Posts: 159  Master Member
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓

    Not 100% sure, but there could be a chance your settings can become mangled. If it is a trivial procedure to make notes of your current settings and add them back manually after upgrading, then it should be safe to upgrade by resetting your device first, then upgrade, then rebooting and adding your settings manually.

    If your existing settings are complex and you would want to keep them as intact as possible, you probably want to upgrade via intermediary versions, just to be on the safe side (I don't remember which firmware versions are known to be hard limits for keeping your settings).

All Replies

  • smb_corp_user
    smb_corp_user Posts: 159  Master Member
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓

    Not 100% sure, but there could be a chance your settings can become mangled. If it is a trivial procedure to make notes of your current settings and add them back manually after upgrading, then it should be safe to upgrade by resetting your device first, then upgrade, then rebooting and adding your settings manually.

    If your existing settings are complex and you would want to keep them as intact as possible, you probably want to upgrade via intermediary versions, just to be on the safe side (I don't remember which firmware versions are known to be hard limits for keeping your settings).

  • RikHead
    RikHead Posts: 5
    First Comment

    Thanks i'll try.

  • Zyxel_Kevin
    Zyxel_Kevin Posts: 752  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @RikHead ,

    Greeting Forum, Please feel free to contact me if you have upgrade issue.

    Thank you

  • smb_corp_user
    smb_corp_user Posts: 159  Master Member
    First Anniversary 10 Comments Friend Collector First Answer

    @RikHead : Please also read the PDF manual present in every firmware zip-file download.

    The manual (filename is the same as the firmware version) contains a "READ ME FIRST" section, telling you which minimum version you need before upgrading to the newest one. From reading the USG310 files, I found that 4.65 r1 is needed before upgrading to 4.73, but I have not had time to check USG110 yet. Hope you have been successful upgrading your device.

Security Highlight