MG-105 strange connectivity issue

Options
meshur
meshur Posts: 4
First Comment

I have 2 devices directly connected to my 2.5G switch (and two further 1G switches) and have a strange issue. When I power cycle the Ubuntu server (connected directly to zyxel, RTL8125B card), my desktop also directly connected to zyxel (I225-V on motherboard) can not ping or ssh to the server. However, if I log into another server (on the 1G switch, via the zyxel switch), then ssh to the directly connected Ubuntu server (which works), then ping the desktop from the ubuntu server, I can then ssh/ping from the desktop to the ubuntu server. I seem to need to "prime" the connection in the reverse direction, to get it to function normally in the direction I need. Is there an update to address this?

All Replies

  • meshur
    meshur Posts: 4
    First Comment
    Options

    Logs from Unbuntu server

    [ 5.121151] r8169 0000:07:00.0 ens1: renamed from eth0
    [ 11.514456] r8169 0000:07:00.0 ens1: Link is Down
    [ 14.556062] r8169 0000:07:00.0 ens1: Link is Up - 2.5Gbps/Full - flow control rx/tx
    [ 14.556085] IPv6: ADDRCONF(NETDEV_CHANGE): ens1: link becomes ready

  • meshur
    meshur Posts: 4
    First Comment
    Options

    Prior logs (before device rename)

    [ 4.880214] r8169 0000:07:00.0 eth0: RTL8125B, 00:e0:4c:65:xx:xx, XID 641, IRQ 27
    [ 4.916083] r8169 0000:07:00.0 eth0: jumbo features [frames: 9194 bytes, tx checksumming: ko]

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,648  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @meshur,

    I did a local test that connected the Ubuntu server (RTL8125) and laptop (Intel I219-V) directly to MG-105. The laptop can ping the server after a power cycle on the Ubuntu server.

    So, I would like to clarify with you:

    1. Did you try to ping the desktop from the Ubuntu server after you found the desktop cannot ping or SSH to it?
    2. What's the OS version of your desktop and Ubuntu? What's the firmware version of I225-V and RTL8125?
    3. What NIC card is another server using?

    Zyxel Melen

  • meshur
    meshur Posts: 4
    First Comment
    Options

    I found a workaround, which is to add a static ARP entry for the Linux server. So I'm happy for you to close this thread if you like.

    Pinging the desktop from the ubuntu server (called quartz) resolves the connectivity issue (as does clearing the ARP cache on the windows machine). I suspect this is an ARP on Windows 11 only issue.

    Desktop (argon) is Windows 11 V 22H2 Build 22621.2070, fully updated with Intel driver 2.1.3.3 dated 09/02/2023

    Other server (petalite) is Raspberry Pi 4B using on board broadcom ethernet device, Running Linux petalite 5.15.0-1034-raspi #37-Ubuntu