GS1200 DHCP Client and Mikrotik Issue

Hi.
We have Mikrotik devices and Zyxel switches on access level (GS1200-8)
Switches receives address by DHCP from Mikrotik main router.
Sometimes some switches (not all) can’t renew address from DHCP and have status waiting
In mikrotik log we have next messages:
"lease waiting, addressed to me, fix-selecting-init-reboot, init-reboot, authorative or unicast, acquire"
"lease acquire failed: got wrong ip"

What means this record in log? And how fix it, that GS1200 work properly?
Thank you.

P. S. This happened on latest 2-3 firmwares. On older firmwares all work ok.

«13

All Replies

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,526  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited December 2023

    Hi @andyvolk,

    Based on the log you provided, I am not sure if these logs are related to the GS1200 DHCP renewal problem. Could you share the whole log file (during DHCP renewal) for me to check? Also, could you confirm with Mikrotik support to check this log's meaning? What is your Mikrotik router OS/firmware version? Which GS1200 firmware version worked ok?

    Zyxel Melen

  • I write to Microtik support too, but think problem is from Zyxel side. Other devices work ok, and some zyxel switch too.
    After power off/on switch receive address, but after some times (3 days - 1 week) issue appears again.

    Fimware was before V2.00(ABME.1)C0 or older, and works ok.

    Here's full screen from mikrotik log

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,526  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @andyvolk,

    Thanks for the logs. These logs look like your Mikrotik router rejected the GS1200's DHCP request. The Nak packets are usually sent by the DHCP server. In addition, I did a local test in my office with Mikrotik router (RouterOS v6.45.1) and GS1200(V2.00 Patch 3). But there's no problem in my test. The DHCP lease time in my lab was 10 minutes. This is used to speed up reproduction.
    The below screenshots are the logs on my Mikrotik router.


    Zyxel Melen

  • andyvolk
    andyvolk Posts: 11
    10 Comments Friend Collector
    edited December 2023

    This problem appears after some time, and not immediately. If you can please try to build a setup with 3-4 GS1200 with RouteOS 7 and leave it for a week for example.

    When I power off and then power on shitch all works fine for some times. But then lease not receive.

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,526  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @andyvolk,

    Thanks for your feedback. I'm running the reproduction with RouterOS v7.13. In the meantime, could you share your DHCP server configuration with me? I just want to make sure my configuration is the same as yours.

    Zyxel Melen

  • andyvolk
    andyvolk Posts: 11
    10 Comments Friend Collector
    edited December 2023

    Here is my DHCP on Mikrotik

    Also i forget to say, that also on zyxels (and whole network we use VLANs). Settings GS1200 likes this (1 port is uplink to top level switch):

    Maybe it is important to reproduce issue.

    Currenly stats in network for zyxels:

    Total 29 items, 10 of them not receive DHCP address,
    9 from 10 are plugged via Mikrotik CSS326, and one via CRS326.
    Uptime: 8 days

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,526  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @andyvolk,

    Thanks for the update. I'm running the test for a few days. In the meantime, could you share your topology with me? I would like to check if the GS1200 is directly connected to the Mikrotik router.

    Zyxel Melen

  • andyvolk
    andyvolk Posts: 11
    10 Comments Friend Collector

    I do not have topology of this network (it so large), but have topology from similiar network. That topology is smaller, but have same issues with DHCP client.

    Blue lines - fiber link
    greed lines - tagged vlans ethernet link
    black lines - simple link

    Last time DHCP issue was at Zyxels marked 1,2,3,4

  • PeterUK
    PeterUK Posts: 2,590  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer

    Would you be able to Wireshark DHCP on the working firmware and non working firmware? As maybe renew request has changed that the Microtik will not renew

    set lease to 3mins to speed up the capture.

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,526  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @andyvolk,

    Thanks for the topology. To speed up the investigation, could you help capture the DHCP packets on the Mikrotik router when the issue occurs? Please find the capture steps below:

    1. Set the filter conditions and start capturing.
    2. Click the packets button and you will find the captured packets. Please share the results with me. Thanks in advance.

    Zyxel Melen