Upgrade Firmware USG 20W from Version 3.30(BDR.9) / 1.15 / 2016-11-22 10:05:22

Options
JBG
JBG Posts: 6
First Anniversary First Comment

I have a Zyxel USG 20W with firmware 3.30(BDR.9) and would like to upgrade it to the latest version, because I got a notice to upgrade the firewall latest 1.August 2024.

The Update to the newest version with the file 538ABAR0C0.bin runs perfect, but after the reboot it shows me still the old firmware version.

Any ideas?

All Replies

  • PeterUK
    PeterUK Posts: 2,917  Guru Member
    Community MVP First Anniversary 10 Comments Friend Collector
    Options

    As the USG has not been kept upto date when it applies your config it fails it might be best to boot to the new firmware and hold the reset in and start over

  • JBG
    JBG Posts: 6
    First Anniversary First Comment
    Options

    I uploaded 538ABAR0C0.bin again. The I pressed the Reset Button for 5 seconds and the firewall made the reset. After the reset (Password was resetted to default). I changed the password and rebootet the firewall again. I tried this 3 times. Still the same old firmware version.

    What else can I do?

  • PeterUK
    PeterUK Posts: 2,917  Guru Member
    Community MVP First Anniversary 10 Comments Friend Collector
    Options

    If its in the firmware slot for 5.38 theirs no need to upload it again just click reboot for that slot then reset it

  • mMontana
    mMontana Posts: 1,345  Guru Member
    Community MVP First Anniversary 10 Comments Friend Collector
    Options

    Firmware 4.x or 5.x are not compatible with that device. The device you're using (USG 20W) have the latest firmware available (BDR.9).

  • JBG
    JBG Posts: 6
    First Anniversary First Comment
    Options

    OK, that mean the notice from Zyxel to upgrade my firewall to my email adress was wrong?

  • mMontana
    mMontana Posts: 1,345  Guru Member
    Community MVP First Anniversary 10 Comments Friend Collector
    Options

    Or could have… more than one meaning. Actually that device is 3 generation old.

    Current Flex H
    Previously USG Flex (ZLD 5.x)
    Previously several USG devices with ZLD 4.x
    Anyway, with 8 years old firmware… some consideration should be applied.

Security Highlight