DHCP Static Host Setting Conflict, error 4024

Options
Bryan
Bryan Posts: 4  Freshman Member
First Anniversary First Comment
edited April 2021 in Security
When trying to reserve a static ip on a vlan interface on a ZyWall 310 running V4.33(AAAB.0) firmware  I receive the error:
CLI Number: 30
Error Number: -4024
Error Message: 'DHCP static host setting conflict.'
Configuring from the web or CLI makes no difference.  Using a different IP with the same MAC address produces no error, but I need to use this one particular IP.  
  • The problematic IP doesn't appear in the DHCP table.
  • I've scoured every device in my environment looking for any other use of it and found nothing.
  • I've used every net mapping tool I can think of and found it nowhere.
  • Of course I've restarted the entire network.
I can't think where to look next.

Any advice would be much appreciated.

Thanks,
Bryan

All Replies

  • Zyxel_Stanley
    Zyxel_Stanley Posts: 1,366  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @Bryan  

    This log is happening when you configured the same IP address in DHCP server.

    So system doesn’t allow to save it.

    Please check if you configured the same static IP in the other interface.

    (Go to Configuration > Network > IP/MAC binding and check all of DHCP setting one by one)


  • Bryan
    Bryan Posts: 4  Freshman Member
    First Anniversary First Comment
    Options
    Thanks for the quick reply.

    The mystery address is 10.0.10.2 on vlan10.  As you can see (attachment "ip mac binding"), I can configure 10.0.10.3.

    No addresses in 10.0.10.0/24 are configured anywhere other than the vlan10 interface config (attached "vlan 10").  The only one which appears in ip/mac binding is 10.0.10.3 for vlan10, just as you'd expect.

    Thanks again,
    Bryan
  • PeterUK
    PeterUK Posts: 2,714  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Unplug the cable of the interface vlan10 and configure on another interface for VLAN10 to add 10.0.10.2


  • Bryan
    Bryan Posts: 4  Freshman Member
    First Anniversary First Comment
    Options
    I appreciate your taking the time to make the suggestion, PeterUK, but there are other easier solutions to the problem.  I'm seeking to understand it.  (I'm the sort of guy who goes to the doctor with a rash and says, "Yes, I know it will go away in a few days but I want to know what it is."
  • Zyxel_Stanley
    Zyxel_Stanley Posts: 1,366  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @Bryan

    Was the IP address configured in the other interfaces?(except VLAN10)

    Can you also check 10.0.10.2 in other interfaces?

  • Bryan
    Bryan Posts: 4  Freshman Member
    First Anniversary First Comment
    Options
    I appear to have solved the problem by waiting until 4:00 am, backing up the ZyWall's configuration, initializing it to factory defaults, and restoring it while the world (my part of it, anyway) slept.  Apparently the problem was some log-free gremlin below the level of anything the interface can see.

    Thanks for the help just the same.
  • Zyxel_Stanley
    Zyxel_Stanley Posts: 1,366  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    Hi @Bryan
    It's good to know your issue has resolved. :+1:

Security Highlight