Zyxel GS-1920HP

AdamW1
AdamW1 Posts: 3
First Comment
edited August 2022 in Switch

Can Zyxel GS1920-24HP V4.10(AAOC.4) | 09/16/2014 run PoE+ devices?

Accepted Solution

All Replies

  • AdamW1
    AdamW1 Posts: 3
    First Comment

    Thank you for response and advise, I have upgraded my switch to provided firmware.

    One more question if possible: After upgrade, and changing password, each time I click any position in "Web configurator" menu, I need to provide password. Is the way to stop it?

  • AdamW1
    AdamW1 Posts: 3
    First Comment

    FYI, "web configurator" works fine now no issues with credentials popup.

  • Zyxel小編 Lucious
    Zyxel小編 Lucious Posts: 278  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment

    Hi @AdamW1


    Glad to hear that, btw, you can try clear your browser's cache for the credential request popping issue.


    Zyxel_Lucious

  • Hi @AdamW1


    Welcome to Zyxel community~

    GS1920-24HP can support PoE+ (IEEE 802.3at) PD.

    Moreover, the firmware 4.10(AAOC.4) you use is kind of old, we highly suggest upgrading to the latest 4.50(AAOC.2).

    ftp://ftp.zyxel.com/GS1920-24HP/firmware/GS1920-24HP_4.50(AAOC.2)C0.zip


    Zyxel_Lucious

    Hey,

    I've clicked the ftp link here a few times and it asks me for a username and password?

    Should I be using the link another way with a ftp client maybe?

    Thank you,

    Jon
  • Zyxel_Chris
    Zyxel_Chris Posts: 659  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    @jonparker,
    Welcome to the community.
    Please refer to this link instead.
    Chris