ZyWall USG 100 - wrong fs type at boot

Logic
Logic Posts: 5  Freshman Member
First Comment
edited April 2021 in Security
Hi all,
i've a Zywall USG 100 with the following issue...
Suddenly it stops to work...
Connected via serial cable, tryed to restore firmware...config...restore image...i succeed to transfer but when it try to apply get always the same mount error.
This is its actual state:

FLASH: AMD 16M

BootModule Version: V1.13 | 12/10/2010 05:20:17
DRAM: Size = 256 Mbytes

Kernel Version: V2.4.27 | 2015-01-08 20:37:07
ZLD Version: V3.30(AQQ.7) | 2015-01-13 16:30:24

Press any key to enter debug mode within 1 seconds.
.....................



Start to check file system...
/dev/hda2: 13/18216 files (0.0% non-contiguous), 9327/72704 blocks
/dev/hda3: 42/43648 files (0.0% non-contiguous), 11206/174080 blocks
Done
mount: wrong fs type, bad option, bad superblock on /dev/loop0,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

Kernel panic - not syncing: Attempted to kill init!
Rebooting in 180 seconds..


With SYS led always flashing.

Any help/suggestion?

Thanks in advance!

Comments

  • Blabababa
    Blabababa Posts: 151  Master Member
    First Anniversary Friend Collector First Answer First Comment
    Strange, did you power off the device during uploading fw or the fw you downloaded is incomplete? Maybe you can try to recover the firmware, the SOP was mentioned in the release note page 61.
  • Logic
    Logic Posts: 5  Freshman Member
    First Comment
    Yes...i've recovered but it fails to boot.

    Now i'm seeing this during boot:

    FLASH: AMD 16M

    CF read: device 0 not ready

    IDENT command error: 0xf0


    IDENT command error: 0xf0


    ERROR


    BootModule Version: V1.13 | 12/10/2010 05:20:17

    DRAM: Size = 256 Mbytes


    Kernel Version:

    ZLD Version:

    IDENT command error: 0xf0


    ERROR


    Press any key to enter debug mode within 1 seconds.

    .............

    Enter Debug Mode


    USG 100>


  • Logic
    Logic Posts: 5  Freshman Member
    First Comment
    This after uploading firmware:

    USG 100> atkz -f -l 192.168.1.1
    -f -l 192.168.1.1
    OK
    
    USG 100> atgo
    Booting...
    
    
    
    
    Connect a computer to port 1 and FTP to 192.168.1.1 to upload the new file.
    
    
    Firmware received ...
    
    FLASH: AMD 16M
    
    BootModule Version: V1.13 | 12/10/2010 05:20:17
    DRAM: Size = 256 Mbytes
    
    Kernel Version: V2.4.27 | 2015-01-08 20:37:07
    ZLD Version: V3.30(AQQ.7) | 2015-01-13 16:30:24
    
    Press any key to enter debug mode within 1 seconds.
    .....................
    
    
    
    Start to check file system...
    /dev/hda2: 13/18216 files (0.0% non-contiguous), 9327/72704 blocks
    /dev/hda3: 39/43648 files (0.0% non-contiguous), 11098/174080 blocks
    Done
    mount: wrong fs type, bad option, bad superblock on /dev/loop0,
           missing codepage or other error
           In some cases useful info is found in syslog - try
           dmesg | tail  or so
    
    Kernel panic - not syncing: Attempted to kill init!
    Rebooting in 180 seconds..
    


  • Logic
    Logic Posts: 5  Freshman Member
    First Comment
    Sometimes:

    USG 100> atgo
    Booting...
    
    
    
    
    Connect a computer to port 1 and FTP to 192.168.1.1 to upload the new file.
    
    
    Firmware received ...
    Start to check file system...
    /dev/hda2: 11/18216 files (0.0% non-contiguous), 6433/72704 blocks
    /dev/hda3: 11/43648 files (0.0% non-contiguous), 9640/174080 blocks
    Done
    
    Building ...
    
    [Update Filesystem]
            Updating Code
            \
    FLASH: AMD 16M
    
    BootModule Version: V1.13 | 12/10/2010 05:20:17
    DRAM: Size = 256 Mbytes
    
    Kernel Version: V2.4.27 | 2015-01-08 20:37:07
    ZLD Version: V3.30(AQQ.7) | 2015-01-13 16:30:24
    
    Press any key to enter debug mode within 1 seconds.
    .....................
    
    
    
    Start to check file system...
    /dev/hda2: 12/18216 files (0.0% non-contiguous), 23910/72704 blocks
    /dev/hda3: 22/43648 files (0.0% non-contiguous), 9651/174080 blocks
    Done
    mount: wrong fs type, bad option, bad superblock on /dev/loop0,
           missing codepage or other error
           In some cases useful info is found in syslog - try
           dmesg | tail  or so
    
    Kernel panic - not syncing: Attempted to kill init!
    Rebooting in 180 seconds..
    
    I think the eeprom or similiar is out...

  • Zyxel_Charlie
    Zyxel_Charlie Posts: 1,034  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    Hello Logic,
    in order to provide you with a better assistance, I will contact you through private message to proceed with RMA process. 
    Charlie

Security Highlight