USG 310 Skype issues

Agor76
Agor76 Posts: 16  Freshman Member
edited April 2021 in Security
Hi,

once upgraded to firmware 4.30 we're experiencing audio delayes and short video freezes on Skype calls, this happens while using an outgoing trunk containing more than one active members, otherwise, Skype works fine using just one interface as outbound route. This didn't happen with the previous firmware 4.25.
Any clue ?

Thanks

Agor

Comments

  • Zyxel_Charlie
    Zyxel_Charlie Posts: 1,034  Zyxel Employee
    Hello Agor76,
    Since I tested locally with containing more than one active members on trunk, and the issue does not occur, could you please private message the configuration to me for checking further.
    Moreover, I want to know the speed of your wan interfaces.
    Charlie
  • Agor76
    Agor76 Posts: 16  Freshman Member
    Hi Charlie,

    first of all, thanks for your quick reply.
    I raised a ticket to the Zyxel EU support and they told me about a possible link sticking bug affecting the latest firmware, told me also that they will provide me a patched beta release, otherwise, I should wait for the offical release expected on February.
    Forgot to mention that this bug is also affecting other services like LogMeIn and videoconferencing providers like Skype.
    Anyway, let me know if you still want to check my configuration.
    Thanks again, your help is really appreciated.

    Fabio
  • parnassus
    parnassus Posts: 13  Freshman Member
    Agor76 said:

    I raised a ticket to the Zyxel EU support and they told me about a possible link sticking bug affecting the latest firmware, told me also that they will provide me a patched beta release, otherwise, I should wait for the offical release expected on February.
    Hello Fabio, with regard to the "link sticking" bug (particularly nasty on Dual WAN setups)...is it true that link sticking management on Dual WAN setups was really reintroduced with 4.30 (somebody told me that 4.25 Patch 1 should be the version with Link Sticking reintroduced)? I have an USG60 with Dual WAN but I see no difference with 4.25...no "link sticking" configuration is possible from user perspective.
    I was forced to disable Dual WAN balancing (with two ISPs) because connections to corporate banking sites very often went down.
  • Agor76
    Agor76 Posts: 16  Freshman Member
    Hello Parnassus,

    I think that link sticking has been just hard coded into recent firmwares because, as you noticed, there's no way to configure it from the user interface but I'm pretty sure that was there in the past, can't tell you precisely on which firmware, but it was.
    Prior to firmware 4.30, my USG 310 was configured using an outgoing trunk containing 3 active members (from 3 ISPs) balanced with LLF algorithm and I had troubles with many services like Skype, LogMeIn, Hamachi and corporate banking sites too, all solved by turning to only one active member just as you did, absolutely no issues using firmware 4.25.00.
    Now I'm waiting for the patched 4.30 that should be provided from the Zyxel's EU support, I'll let you know if something changes.
    Thanks

    Fabio
  • parnassus
    parnassus Posts: 13  Freshman Member
    Thanks Fabio, months ago ZyXEL Support (Italy) confirmed that Link Sticking was enabled and hardcoded into 4.x ZyOS series with a pre-set value of 300 seconds: I remember that on ZyOS 3.x Link Sticking configuration (enable/disable) and its settings were exposed to Web GUI...I was under the impression that ZyXEL on newer releases (after 4.25) would have re-exposed it into Web GUI...but probably I misunderstood.
    Davide.

Security Highlight