Older Zyxel USG firmware NOT available via FTP, only latest revision at portal.myzyxel.com

CoreSG
CoreSG Posts: 34  Freshman Member
I have a couple Zyxel USG devices that are a bit far behind on firmware.

Saw a post elsewhere here to look  for older firmware updates at ftp.zyxel.com
PROBLEM:

For a USG20VPN for example, the ftp site has up to 4.20.
The updates offered via portal.myzyxel.com are only the 4.6 branch.
I need (for one USG20VPN) all of 4.30 > 4.3.2 > 4.3.8 > 4.62
to follow the recommended path.

I called US "support," was on hold until I got a message saying there are not techs available, call back, and hung up.

This is beyond ridiculous and worthy of a whole string of cusswords (pick your favorites).
Is there an EU number I can call at least ? Last time I got routed through to there I was able to get actually knowledgeable support.

All of this to call someone to hopefully get a working link to available older firmware updates.



All Replies

  • Mario
    Mario Posts: 69  Ally Member
    Hi CoreSG
    Please check ftp://ftp.zyxel.com/USG20-VPN/firmware/ you find 4.35

    Maybe an upgrade from 4.35 to 4.60 is possible...




  • PeterUK
    PeterUK Posts: 1,118  Guru Member
    Just go to V4.64 should be fine just backup your config 1st.
  • CoreSG
    CoreSG Posts: 34  Freshman Member
    edited June 29
    Thank-you. But you're missing part of the point of my post.
    The guide for 4.35 says "
    1. Recommended upgrade to ZLD4.32 C0 or later version first before upgrading

      to ZLD4.35.

    "
    Where is 4.32 ? It's not there, not the firmware, only the PDF. So it's safe to jump to 4.33 when the 4.35 guide calls for 4.32 ? Can you confirm this with a link to a statement from Zyxel somewhere other than this forum ?

    What's (the reason for) the difference in the listings, and why some are weekly-type firmware updates ?

    Should I use 433ABAQ0ITS-WK19-r88384.zip or 433ABAQ0ITS-WK12-r87753.zip and why ?





  • Zyxel_Can
    Zyxel_Can Posts: 342  Zyxel Employee
    edited June 29

    Hi @CoreSG,

     

    Which devices’(model's) 4.32 firmware you need?

  • CoreSG
    CoreSG Posts: 34  Freshman Member
    Hi Zyxel_Can - thanks. In this case, specifically a USG20VPN.
  • Zyxel_Can
    Zyxel_Can Posts: 342  Zyxel Employee
    Hi @CoreSG,

    I sent you the firmware by private message.
    Please kindly check your message box.
  • Mario
    Mario Posts: 69  Ally Member
    @CoreSG I just needet to update a spare USG60 from 4.35 to 4.64. Did a direct update, and it worked.

Security Highlight