Unable to register USG210

elkrust Posts: 22  Freshman Member
edited September 2021 in Security

We have taken over the support of a Zyxel USG210 but when I tried to add it to our Zyxel Portal I get the following error message "device has already been registered". I have followed these instructions but get the same error.


I would appreciate any help for this. Thanks

All Replies

  • CHS
    CHS Posts: 144  Ally Member
    You can try to login to MyZyxel first, and then click URL on device.
    It will auto fielded serial number and MAC address. It  should no problem to register to your account.
  • elkrust
    elkrust Posts: 22  Freshman Member
    I am afraid that didn't work.
  • elkrust
    elkrust Posts: 22  Freshman Member
    CORRECTION - I have just tried this again with Firefox on my Mac that I have set up in private browsing mode and it has actually worked. I was able to re-register the unit to myself. It could have been a caching issue with Safari on my Mac. Thanks for your help.

Security Highlight