NWA210AX How to debug slow 5GHz connection?

Steini
Steini Posts: 3
Hi, 
in my setup I have an NWA210AX powered via POE12-30W connected to a 2.5 GBit Port of an XGS1210-12. At another 2.5 GBit port of that switch I have a server which runs an IPerf3 server. From another computer it can max out the 2.5 Gbits, so that is working fine.

With a MacBook Pro (14-inch, 2021) (and every other device I tried) directly next to the NWA210AX the 5 GHz connection is basically unusable.

With disabled 5G radio:
[  7] local 192.168.10.57 port 57001 connected to 192.168.10.2 port 5201
[ ID] Interval           Transfer     Bitrate
[  7]   0.00-1.00   sec  16.5 MBytes   138 Mbits/sec
[  7]   1.00-2.00   sec  18.3 MBytes   153 Mbits/sec
[  7]   2.00-3.00   sec  17.6 MBytes   148 Mbits/sec
[  7]   3.00-4.00   sec  18.6 MBytes   156 Mbits/sec
[  7]   4.00-5.00   sec  18.5 MBytes   155 Mbits/sec
[  7]   5.00-6.00   sec  18.8 MBytes   157 Mbits/sec
[  7]   6.00-7.00   sec  17.4 MBytes   146 Mbits/sec
[  7]   7.00-8.00   sec  18.6 MBytes   156 Mbits/sec
[  7]   8.00-9.00   sec  16.5 MBytes   138 Mbits/sec
[  7]   9.00-10.00  sec  19.3 MBytes   162 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  7]   0.00-10.03  sec   184 MBytes   153 Mbits/sec    2             sender
[  7]   0.00-10.00  sec   180 MBytes   151 Mbits/sec                  receiver
With 5G radio:
[  7] local 192.168.10.57 port 57309 connected to 192.168.10.2 port 5201
[ ID] Interval           Transfer     Bitrate
[  7]   0.00-1.00   sec  7.07 KBytes  57.7 Kbits/sec
[  7]   1.00-2.01   sec  4.24 KBytes  34.7 Kbits/sec
[  7]   2.01-3.00   sec  0.00 Bytes  0.00 bits/sec
[  7]   3.00-4.00   sec  0.00 Bytes  0.00 bits/sec
[  7]   4.00-5.00   sec  0.00 Bytes  0.00 bits/sec
[  7]   5.00-6.01   sec  8.48 KBytes  69.0 Kbits/sec
[  7]   6.01-7.00   sec  7.07 KBytes  58.3 Kbits/sec
[  7]   7.00-8.00   sec  7.07 KBytes  58.1 Kbits/sec
[  7]   8.00-9.00   sec  1.41 KBytes  11.6 Kbits/sec
[  7]   9.00-10.00  sec  1.91 MBytes  16.1 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  7]   0.00-10.01  sec  2.46 MBytes  2.06 Mbits/sec   59             sender
[  7]   0.00-10.00  sec  1.94 MBytes  1.63 Mbits/sec                  receiver
The Mac shows me RSSI: -31 dBm, Noise -88 dBm. TX Rate 1.2 GBit. The maximum power is set to +30 dBm, the NWA uses +16 dBm(?).


To configure the device I have to walk away until it switches to 2.4 GHz and then I can use the web interface again ...
What can I do to debug this? Thanks!

All Replies

  • Zyxel_HsinBo
    Zyxel_HsinBo Posts: 51  Zyxel Employee

    Hi, @Steini



    Welcome to Zyxel Community!

    According to your description, your station with good signal connect to 5GHz perform badly but it does well at 2.4Ghz.

    There may be many reason cause low speed,

    For radio channel selecting, there would be a clear choice in DFS for AP if there isn’t a Radar service, could you kindly help us to disable “Enable 5 GHz DFS Aware” function in 5GHz radio setting.

    Observing your stations connection status and check if the issue is solved or not.

     

    If the problem is still unsolved, please help us collecting the diagnostics file from AP then send it to us by PM me!

     

    Path: MAINTENANCE >> Diagnostics >> Collect Now

     

    Sorry for this bad experience, we will solve this problem as soon as possible.

    Thank you.

     

    Best Regards,

    HsinBo

     

  • Zyxel_HsinBo
    Zyxel_HsinBo Posts: 51  Zyxel Employee
    Hi, @Steini


    We have checked your diagnostics file in the past few hours.
    Unfortunately, since the 5G radio is deactivated, there are some lack of 5G radio information in Diag. that we require.
    But at the same time, we discover your station (Macbook) constantly intra-roaming from a poor signal detected in the 5G connection log.
    Since stations disassociate and associate constantly, it must cause unstable transmit performance.



    Thre are some settings that need your assistance to avoid it happening so that you can collect the necessary data which we need!
    Could you kindly help us set up by following the steps below :

    1. Activate both of your 2.4G and 5G radio, separate your 2.4G and 5G SSID (By setup different SSID names) then apply in your radio/  SSID/AP profile settings.
        ( This action prevent constantly intra-roaming from the same SSID under 2.4/5G during collecting a complete Diag. file )

    2. After you have done the settings from Step. 1, reboot your NWA210AX.


    3. Until AP reboot finished about 20 minutes, please do the speed test again (iPerf), and collect a new diagnostics file for us.
        ( PATH : MAINTENANCE >> Diagnostics >> Collect Now )

    Sorry for the complex setup which need your help, we would figure the problem as soon as possible
    Have a nice day, and thank you!



    Best Regards,

    HsinBo

  • Steini
    Steini Posts: 3
    Thank you very much for looking into my issue. I created a new 5G network and repeated the speed test with the same slow results. I sent you the new diagnostics file via PM.
    Thanks!
  • Zyxel_HsinBo
    Zyxel_HsinBo Posts: 51  Zyxel Employee
    edited May 11

    Hi, @Steini

    We are still tracing the issue of your case and there are some discover as below:

    After we analyze your diagnostics, there is no hardware broken message in the log record, and we have tried to simulate your environment with the same model and same setting config, everything works fine.

    Thus, we are going to check if there is a network environment issue, here still need your help to provide more information and do some settings.

    Could you kindly help us to describe your network topology ? (There are how many Access Points, switch ... in your network and how they connect together)

    If there is more than one AP in your network, does 5G low speed happens at clients connect to other APs?

    Do all of your stations connect to NWA210AX 5G SSID perform badly?

    The result of the iperf test you provided are connected to which SSID(2.4G/5G)?

    (There may be an influence if you test with a different VLAN)

     

    The following steps may need your help to set up the NWA210AX:

     

    1.    We use radio to scan the channel environment based on the first SSID, thus, you need to turn on the first SSID in the SSID table of 5G radio from AP Profile. (Default or any SSID profile is fine)

    2.    Waiting for 20 minutes, please help us to collect the diagnostics file.

     

    Last, may I ask if you are willing to let us remote your station for tracing the problem directly?

    We would do some tests base on your current environment and setting to confirm the issue.

    Sorry for this late reply and for bringing you so much inconvenience.

    Thank you.

     

    Best Regards,

     

    HsinBo

     


  • Steini
    Steini Posts: 3
    edited May 11
    Hi @Zyxel_HsinBo,
    thank you so much for your help.
    1.    We use radio to scan the channel environment based on the first SSID, thus, you need to turn on the first SSID in the SSID table of 5G radio from AP Profile. (Default or any SSID profile is fine)
    Actually, when preparing the next tests I moved the 5G wifi to the first SSID and everything works now as expected!
    Initially I had 3 Wifi's on different VLANs configured, the first being the IoT-Wifi. I then realised that most devices only use 2.4G anyway and the others have problems with switching. Furthermore, the traffic is low. So I disabled the config leaving SSID#1 disabled.
    I have no time now to reproduce the problem, but wanted to leave you a note asap.
  • Zyxel_HsinBo
    Zyxel_HsinBo Posts: 51  Zyxel Employee
    Hi, @Steini

    Glad to hear that everything go fine with your 5G network, 
    Thanks for doing so much that help us trace the issue.
    We would keep concentrating on this case, 
    If there is still any problem or findings, please do not hesitate to contact us!
    (Update post in this discussion or PM us is fine)!
    Have a nice day, Thank you!

    Best Regards,

    HsinBo