uOS usage : physical port extension of an already configured interface...bizarre behaviour

Options

I continue posting issues/question I encounter for others to maybe find answers.

I stumbled over a problem in the interface definition.

I have defined an internal ethernet interface on P2

I have then added several Vlans also on P2

That is all working perfectly

*******************************

Now I wanted to expand the P2 interface to other physical ports (starting with P5). I cannot do so. When I want to add let's say P5 and or P..X (which are all not bound ie free) when I try to add them on above mentioned interface (P2) by selecting any one of them in the drop down it REPLACES P2.

  1. Trying to understand how this comes I defined another internal ethernet interface on P8. I then added 2 other vlan interfaces to P8. I then tried the same thing and tried to expand P8 to other physical ports. Selecting other physical ports in the drop down ADD to it.

I haven't found out why with my P2 interface this is not working…

Accepted Solution

  • Zyxel_Kevin
    Zyxel_Kevin Posts: 813  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options

    Hi @eddyshere ,

    Thank your useful information. This is current limitiation we list in Release Note.

    Please kindly refer the Relase Note. Thank you

    https://download.zyxel.com/USG_FLEX_500H/firmware/USG%20FLEX%20500H_1.10(ABZH.1)C0_2.pdf

    Share yours now! https://bit.ly/4aO0BMF

    Kevin

All Replies

  • PeterUK
    PeterUK Posts: 2,915  Guru Member
    Community MVP First Anniversary 10 Comments Friend Collector
    Options

    Could the reason be that P2 is 2.5Gb and P5 is 1Gb ?

  • eddyshere
    Options

    I don't know. Looking at the default table :

    It might give a hint. It would appear that whilst advertized as freely configurable I'm wondering if regarding P1-P4 the "assumed" use case is P1, P2 = WAN's and P3 to P12 whatever. As a result any interface on P1 or P2 cannot be expanded to other physical ports.

    As P1 to P4 are 2.5GBE so quite normaly if you have 1x10GBE ISP you will have to use P1, P2 either as WAN or LAN. The problem being that this LAN which usually goes to your switches you cannot expand over P3 or P4 to benefit from POE for same LAN.

    In short in uOS I could not expand interfaces using P1 or P2 over any other physical port.

    In the search of workarounds I found out something other which made me scratch my head :

    whilst i cannot expand P2 over other ports I can duplicate it. ie I can define for let's say P5 an interface which has the exact same IP address and netmask than the interface I already have on P2. It's obviously not really working but interesting

    In the "old" flex500 doing so yielded in an error message and was not possible but here it's possible. Only limitation i saw is then obviously the DHCP server which can be activated only on one of these two interfaces. So one could be switched to "relay".

    Am still testing and trying to understand…

  • Zyxel_Kevin
    Zyxel_Kevin Posts: 813  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @eddyshere ,

    Greeting forum,

    Could you provide your module and firmware verison. (the latest is 1.10Patch1)

    For the issue#1 , I follow the steps but can't reproduce, Please kindly check my steps.

    -Add a static IP for Ge2 (p2) , Create Vlan based on P2.

    -Add another unuse physical ports (P5, P8) into Ge2. but the P2 isn't replaced.

    For the issue#2, I have raies Feature Request to change the behavior.

    Thank you

    Kevin

    Share yours now! https://bit.ly/4aO0BMF

    Kevin

  • eddyshere
    Options

    Hi Kevin,

    Thanks for your answer

    Module number ?? where would i find this ??

    Firmware : latest V1.10(ABZH.1).

    In the meantime I have reset the Firewall and tried on the green field. Neither P1 nor P2 can be used in an interface with any other port. P3 and P4 can. And all the others can as well

  • Zyxel_Kevin
    Zyxel_Kevin Posts: 813  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options

    Hi @eddyshere ,

    Thank your useful information. This is current limitiation we list in Release Note.

    Please kindly refer the Relase Note. Thank you

    https://download.zyxel.com/USG_FLEX_500H/firmware/USG%20FLEX%20500H_1.10(ABZH.1)C0_2.pdf

    Share yours now! https://bit.ly/4aO0BMF

    Kevin

  • Noksu99
    Noksu99 Posts: 3
    First Comment
    Options

    Hi,

    It seems that port 13 and 14 cannot perform as a port group together as well? I have 700H with 1.10(xxxx.1) firmware I can't make LAG with any ethernet interface or physical ports. Web interface doesn't give option for that

    How can I make LAGs?

    br. Kristian

  • PeterUK
    PeterUK Posts: 2,915  Guru Member
    Community MVP First Anniversary 10 Comments Friend Collector
    Options

    From what I know there is no LAG support on H models yet

  • Noksu99
    Noksu99 Posts: 3
    First Comment
    edited January 18
    Options

    Perhaps so, but it's interesting it has been mentioned in user's guide ed. 1.10. I hope real world and instructions will meat also in Zyxel user's guide.