Dibbley Posts: 2
edited May 5 in Switch

I have a LAN at work I want to split into 2 networks using VLAN (Once I know the process to create 2, then I'll make 3 and 4).  I have successfully managed to split the network into 2 for all devices physically connected to the switch via the ethernet ports.  However, I did this via trial and error rather than by a knowledge of VLANs. The PCs in the Green group (picture below), cannot see the the PCs in the Pink group, and vice versa.  All PCs can see the internet.

What I have not been able to do, is to configure the Wifi to work like I have the physical cabling.

The hardware I have is a GS1900-24HP switch and NWA1123-AC PRO Wireless APs.

Is there something obvious that I am missing to get this to work.  Below is a pic of the configuration of the switch and APs


All Replies

  • Zyxel_Adam
    Zyxel_Adam Posts: 137  Zyxel Employee
    Hi @Dibbley,

    Welcome to Zyxel Community.

    We suggest that those switchports for connecting PCs should change to untagged and assign PVID for a specific VLAN.

    For example,the green group from port 6 to 11 should be configured to PVID 101 and untagged on VLAN 101. In addition, the pink group from port 12 to 16 should be configured to PVID 102 and untagged on VLAN 102.
  • Dibbley
    Dibbley Posts: 2
    edited May 6

    Thanks for replying.

    I've made the changes below, but I'm still not getting any connectivity over the Wireless APs when I set the VLAN to 101 or 102 respectively.  I notice I cannot change the PVID within the SSID settings where I set the VLAN ID.  I'm using Nebula to configure the APs.

  • Zyxel_Adam
    Zyxel_Adam Posts: 137  Zyxel Employee

    For the PCs, they are now in the right way.
    However, for APs, you may change the VLAN setting back to tagged for switchport 2-5, and configure vlan 101 for SSID 1 and vlan 102 for SSID 2 on SSID settings page of NCC.
  • PeterUK
    PeterUK Posts: 1,090  Guru Member
    edited May 7

    Change the management VLAN to 101 or 102 check you can access the switch then forbidden for VLAN1 6-16

    Have you a router with VLAN 101 and 102? as you need to set tagged for VLAN 101 and 102 for port 1