Spontaneously reboot

jonatan
jonatan Posts: 76  Ally Member
edited April 14 in Security
Hi have a device of Zyxel Zywall 310 firmware 4.30(AAAB.0). The gateway can spontaneously reboot in the system status panel, the Boot Status - Fallback to lastgood configuration. What to do?
«1

Comments

  • Zyxel_Emily
    Zyxel_Emily Posts: 808  Zyxel Employee
    edited March 2018

    Is the ZyWALL 310 running with UTM functions enabled?
    If the answer is yes, we already have fix for this reboot issue. 
    I send the date firmware to you via private message for verification.

    If the answer is no, please also upgrade ZyWALL 310 to the date firmware and give us more information as follows.
    1. How often did the ZyWALL 310 reboot? 
     
    2. Use the command to get the disklog and send the disklog to us.
    Router# show software-watchdog-timer log

    3. Connect ZyWALL 310 with console using TeraTerm and enter the command.
    Router> debug kernel console-level 8
    Then keep collecting console logs and save all console logs to a txt file until the device reboots again.
    Attached is the document with steps for logging console logs to a file.

    Emily
  • jonatan
    jonatan Posts: 76  Ally Member
    There were no spontaneous reboots after the firmware update.However, if you change the configuration and then restart the device, the changes are not saved.The system status panel, the Boot Status - Fallback to lastgood configuration.It may be the case in the configuration , it is possible as that to check for correctness?
  • jonatan
    jonatan Posts: 76  Ally Member
    The problem was solved by fixing the configuration file.
  • ewing
    ewing Posts: 17  Freshman Member

    Is the ZyWALL 310 running with UTM functions enabled?
    If the answer is yes, we already have fix for this reboot issue. 
    I send the date firmware to you via private message for verification.

    If the answer is no, please also upgrade ZyWALL 310 to the date firmware and give us more information as follows.
    1. How often did the ZyWALL 310 reboot? 
     
    2. Use the command to get the disklog and send the disklog to us.
    Router# show software-watchdog-timer log

    3. Connect ZyWALL 310 with console using TeraTerm and enter the command.
    Router> debug kernel console-level 8
    Then keep collecting console logs and save all console logs to a txt file until the device reboots again.
    Attached is the document with steps for logging console logs to a file.

    Emily
    Hi, I´m still workin with firmware v4.25, the v4.30(AAPJ.0) has the same problem reboot? because I got and IDP license and I have the reboot issue.
  • Zyxel_Cooldia
    Zyxel_Cooldia Posts: 787  Zyxel Employee
    Hi @ewing,
    Can you follow Emily’s instruction to help us collect console log for analyzing.
    Attached is the document with steps for logging console logs to a file.

  • nacho
    nacho Posts: 2  Freshman Member
    Good day, I have the same issue, i have USG1900 running on V4.33(AAPL.0) / 2019-01-09 09:38:28

    the latest firmware,what is the cause?
  • Zyxel_Stanley
    Zyxel_Stanley Posts: 946  Zyxel Employee

    Hi @nacho

    Have you done anything before system reboot itself?

    How often the symptom will happen again?

    Can you go to collect diag-info and forward it to me by private message?

    (Maintenance > Diagnostics > click “collect now” and wait for around 5 mins. And go to “Files” to download the file)

  • nacho
    nacho Posts: 2  Freshman Member

    Hi @nacho

    Have you done anything before system reboot itself?

    How often the symptom will happen again?

    Can you go to collect diag-info and forward it to me by private message?

    (Maintenance > Diagnostics > click “collect now” and wait for around 5 mins. And go to “Files” to download the file)

    Hi Stanley,
    Nothing was done before then. I gave sent you the files now
  • cdiaz
    cdiaz Posts: 2
    jonatan said:
    The problem was solved by fixing the configuration file.
    Please, tell me the detail how fix it. Thank you
  • mMontana
    mMontana Posts: 370  Master Member
    @cdiaz are you still using old firmware or the current one for your device?

Security Highlight