[solved] GS1920-24v2 VLAN config issue

MikeyTT
MikeyTT Posts: 3
edited June 2 in Switch
I currently have a few TP-Link switches (TL-SG1024DE,TL-SG1016) with VLANs to segment my main, vpn and lab traffic. I have them setup as per the image below:

I've tried to replicate this in the pair of GS1920-24v2 switches using the static vlan option. This is how I've configured it:




The only difference to the way it's wired up is that for each of the vlans on the TP-Links I have a network cable from that vlan to the same vlan ports on the other switches. On the Zyxel I am using one of the 4 x GBe Interfaces with a single ethernet cable between the two.

I have a dhcp server sat on each of the vlans. With the TP-Link I'd get an IP from the subnet I expect. With the Zyxel switches I get a 192.168.3 address every time. If I stop the 192.168.3 dhcp server I do indeed get 192.168.0 addresses as expected.

I'm using untagged everywhere just to simplify life and this is the how the network is/should be configured:



I'm guessing that the switch is preferring vlan 103 traffic for some reason, but I'm at the end of my current networking knowledge to figure out why unfortunately. 



Accepted Solution

  • MikeyTT
    MikeyTT Posts: 3
    edited June 2 Accepted Answer
    Got it all sorted and working. It's not very clear from the user guide, nor the example vlan config they give but you need three additional configurations to make it work with the GBe connections.

    On the vlan you create you also need to add the 4 GBe ports and ensure "Tx Tagging" is enabled. Then in the "VLAN Port Setting" page you need to match your port assignment with the pvid's here, then finally leave the pvid at "1" for the GBe connections, but enable "Port Trunking":


All Replies

  • Zyxel_Chris
    Zyxel_Chris Posts: 395  Zyxel Employee
    @MikeyTT,
    Based on your Vlan100 screenshot (I assume it is the GS1920 in the right hand of your topology), port 1 and port 26 should check the TX tagging checkbox, also because the port26 is the trunk port therefore all VLANs should fixed on this port with tagging. (On both GS1920)
    If still has the issue, can you please collect the tech support file in Maintenance Diagnostic>Tech-support and download "All" and let me know which one is the GS1920 on right and which one is on left.
    Chris
  • MikeyTT
    MikeyTT Posts: 3
    Thanks for the reply. The config on the switches is identical apart from the management IPs. I have port 26 set with TX Tagging on both switches. Port 1 on the right hand switch I've left without as I don't use tagging in dhcp. 

    I suppose I could simplify further and have a single upload port to pfSense and then use tagging, but as a non-network techie my brain is better if I have the segmentation :)
Sign In to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click on this button!