VLAN835 ON WAN - ATP700

New provider ask to set VLAN 835 when connect with PPPoE. If i use standard router provided with internet service, it works fine. If i try to configure the connection on ATP700, dosn't work. I followed this steps for the configuration: 

https://support.zyxel.eu/hc/it/articles/360001390334-Configurazione-di-una-VLAN-su-un-interfaccia-WAN-PPPoE

Don't know what is wrong...are there some routing or policy to add to allow this feature? 

Accepted Solution

  • Antares3000
    Antares3000 Posts: 15
    Accepted Answer
    SOLUTION: In ISP Account "Service Name" was not empty. Deleting the content it worked.

All Replies

  • Zyxel_Can
    Zyxel_Can Posts: 341  Zyxel Employee

    Hi @Antares3000,

     

    Can you provide your topology with IP addresseses on it?

     

    Apart from the settings ATP700, you will also need to configuration on your Switch.

     

    On the switch site, make sure you have applied the following configuration:

    1-    Create VLAN835 on your switch

    2-    Set the port connected to ISP’s line as Untagged

    3-    Set the port connected to your ATP700 as Tagged


    Ex:In the screenshot above;

    Port 23 is connected to ATP700’s PPPoE interface

    Port 24 is connected to ISP’s cable
  • Antares3000
    Antares3000 Posts: 15
    I understood your idea. I didn t use switch in the middle. I connected atp700 pppoe interface directly to isp cable. Isn t it possible to make it works in this way? Do i need switch?
  • Zyxel_Can
    Zyxel_Can Posts: 341  Zyxel Employee
    edited June 30

    Hi @Antares3000,


    If your WAN PPPoE running on VLAN interface, yes, you will need a VLAN supported switch in that scenario or the tagged packets won’t be recognized by the ISP.


    You can have a look a switch that meets your needs from the following link;

    https://www.zyxel.com/products_services/home-switches.shtml?t=c


  • Antares3000
    Antares3000 Posts: 15
    I did as you suggested. 

    To test if i configured as well , i removed vlan from the router that provider gave to me (tplink). Than i tried to connect directly and didn't work. Than i connected tplink to configured vlan 835 switch and it worked. So i'm sure that switch is configured as well.

    So i connected my ATP700 instead of tplink...but didn't work. In log, nothing displayed.

    My topology is easy...i bought a new atp700 and the first thing i tried to do is to connect PPPoE. So nothing special on ATP700.
  • PeterUK
    PeterUK Posts: 1,089  Guru Member

    Don't have a ISP needing PPPoE but would you just need to make a VLAN on base port WAN1 with a made ISP account then make PPP from for that account to use base interface VLAN?


  • Antares3000
    Antares3000 Posts: 15
    Yes, it was what i did but seems that dosn't work with Zyxel. I also tryed with USG60W and i have the same problem
  • Antares3000
    Antares3000 Posts: 15
    I also tried a simpler router...Zyxel NBG6615. Noway to connect using PPPoE. If i use other brands, no problem. Does Zyxel use a different PPPoE ???
  • Zyxel_Vic
    Zyxel_Vic Posts: 226  Zyxel Employee
    Hi @Antares3000
    No, we didn't. Can you help to capture the packets in WAN when the ATP700 start to do PPPoE negotiation with the ISP? I think packets can tell.
  • Zyxel_Can
    Zyxel_Can Posts: 341  Zyxel Employee

    Hi @Antares3000,


    Apart from WAN interface we will also need PPPoE interface and VLAN interface's packets.

    Can you please capture packets when you are dialing PPPoE connection?

     

    Please capture packets for following interfaces:

     

    1- VLAN835 interface

    2- Your WAN interface that used for PPPoE connection

    3- PPPoE interface that you bound your ISP Account object

     

    Please send me the captured packets by private message.

    You can find capturing packet section under Configuration > Diagnostics > Packet Capture > Capture menu.

     

    Example screenshot:


Security Highlight