My USG110 won't upgrade to its latest firmware

Hello,
my company has a zyxel USG110. I tried many times to upgrade its firmware but to no avail. Firmware level is V4.62(AAPH.0). I tried to upgrade its latest firmware 4.65(AAPH.0), but every time the firewall restarts it remains at the same firmware level as before.
I tried to update by "cloud firmware" at first, the I tried to download firmware in the local computer and to send it to the firewall. Then I tried with FTP upload technique. No result at all. The interface didn't show any error at all. I'm worried about the latest vulnerabilities and need your help to update as soon as possible. Thank you for your help.

All Replies

  • mMontana
    mMontana Posts: 1,300  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Hi Marco,
    My name is Michele, and I am a network technician from Italy.
    Register yourself to portal.zyxel.com, If you did not already do. After that, download to your computer all the three firmware available for USG110, which are 4.63, 4.64, 4.65.

    In my opinion is mandatory, create a rule for lock out https management from WAN before starting. If you're offsite, consider to create a temporary L2TP/IPSec for remote manage the device.

    • Delete all user-object that are not meant to be there
    • Clean all SSL-VPN which are not expected to exist
    • After ensuring yourself that you can access via the backup connection, after enabling the admin-wan-lockout rule reboot your firewall still on your current partition
    • After reboot, verify that everything is still as you expect
    • Clean older configurations if they are present, create a backup configuration of your current setup.
    • Manual update the standby partition with 4.63 without reboot (don't user Firefox, it "freezes" usually on the time for flashing and it's not telling you the truth about the end of the flashing procedure; i am fan of Firefox, FWIW).
    • Ensure yourself to click on standby partition and therefore reboot  your Firewall
    After this procedure you're should be able to cloud update the firmware from 4.63, but please... take your time verify that everthing is where is supposed to and is working as expected (obviously without SSLVPN and WAN-HTTPS admin).

    Keep me posted, please...
  • Zyxel_Stanley
    Zyxel_Stanley Posts: 1,366  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @MarcoBozzi

    Did you upgrade firmware to “Standby” partition?

    If yes, then the reason should come from configuration error and caused system rollback to previous partition.

    You can send startup-config to me by private message for further check.

  • Ok, I tried to upgrade  "active partition", that's why, maybe, it didn't work. I will try again with "stand-by" partition and let you know. Thanks for the moment.

Security Highlight