SecuExtender Adapter Doesn't Install on Windows 10 v1709

DiafindLTD
DiafindLTD Posts: 3  Freshman Member
Friend Collector First Comment
edited April 2021 in Security
Hello,

When attempting to install the latest version of ZyWall SecuExtender on a brand new Windows 10 Pro x64 v1709 laptop, it seems the setup fails to install the necessary network adapter.

I've tried running the setup as administrator. I've also tried cleanly uninstalling SecuExtender, rebooting, and performing a new installation. I disabled my ESET antivirus and firewall completely when doing so to prevent them from interfering.

Every time I run the setup the software installs fine and I get no error messages. However, the installation hangs when installing the IA64 network adapter for several minutes with no progress. Afterwards, the setup claims it has finished completely, but the adapter remains uninstalled and the SecuExtender software does not open at all.

It's worth noting there are 2 other VPN solutions installed on this PC and both of them work as well as their respective network adapter drivers.

Any help would be appreciated,
Ofer Dottan
Diafind LTD.

Comments

  • Zyxel_Cooldia
    Zyxel_Cooldia Posts: 1,444  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Hi @DiafindLTD,

    Welcome to Zyxel forum.
    It looks like windows driver signing issue. does your host enable secureboot?
    If it is enable by default, can you disable it and try it again.


    How to check whether the secureboot function is enabled
    -Click on the windows start button
    -Enter "msinfo32.exe" in the run bar

    -Check whether the line "Secure Boot State On" is displayed or not

  • DiafindLTD
    DiafindLTD Posts: 3  Freshman Member
    Friend Collector First Comment
    Hello @Zyxel_Cooldia unfortunately my previous customer decided to drop the issue and I was unable to follow up.

    I ran into the same issue on another Windows 10 Pro laptop. Different make and model and different customer.

    The user is a local administrator, secure boot is OFF and Windows is updated.

    Here is the user's MSINFO32 summary, personal information redacted -


  • DiafindLTD
    DiafindLTD Posts: 3  Freshman Member
    Friend Collector First Comment
    To anyone reading this thread who is experiencing similar issues:

    The issue seems to be a conflict between SecuExtender and other VPN clients such as Fortinet Forticlient. To resolve this issue:

    1) Remove other VPN software such as CheckPoint VPN or Forticlient.
    2) Restart your PC if necessary.
    3) Install Zyxel SecuExtender and make sure it works.
    4) [OPTIONAL] Download more updated versions of the uninstalled VPN clients.
    5) Re-install other VPN software.
    6) Test to see if everything works as expected.

    A big thank you to Cooldia for following up on this issue until a solution could be found.

Security Highlight