GS1900-24 dead within hours of update to V2.70(AAHL.0)

After many years of operation and numerous other successful firmware updates, my GS1900-24 failed operation just a few hours after I uploaded V2.70(AAHL.0) from V2.40 previously installed.  At the time, I noted the new firmware home screen was broken (Brave browser).  Rendering of active ports / LEDs was misaligned with the base image of the switch.  In this condition, the browser was very unresponsive.  This may have been a Brave-specific issue as it seemed to work with Edge, so I moved on.

Fast-forward less than 12 hours, and the switch completely failed.  No link lights whatsover are possible.  Only the PWR LED is lit.  No activity on any other LEDs occurs during power up or when connecting ethernet cables.

There were no source power anomalies in the hours between firmware updating and the failure.

I've tried power cycle.  I've tried holding reset while powering up.  I've tried holding reset 10+ seconds and then power-cycling.

It seems a bit unlikely to experience a random failure like this co-incidentally in close proximity to a firmware update.  It could happen, but it sure seems like the failure might be related.

Any thoughts on how one might attempt a recovery of the device?

All Replies

  • Zyxel_Jason
    Zyxel_Jason Posts: 371  Master Member
    edited December 2021
    Hi @Brayvin,

    Welcome to Zyxel community!

    We would want to know if your problem is really related to the firmware upgrade or actually the hardware.
    Therefore, we would need some time to reproduce and investigating the problem because, form your description, it happens the problem after running 12 hours and we don't have other cases that report the same symptom recently.

    BTW, do you remember which patch of V2.40 was on your GS1900?
    For example: V2.40(AAHL.0) is patch 0.

    Jason
  • TiggerLAS
    TiggerLAS Posts: 63  Ally Member
    I also have to report a similar issue that started several days after
    moving to 2.70(AAH0.0) on a GS1900-48HP rev A1.

    One evening, all of the IP phones in our office started power-cycling themselves in a
    repeating loop, with about 1-second intervals.   I restarted the switch, and all seemed
    to be well again. . . until a few days later, when the switch started doing it again.

    Personnel found the phones to be in another power-cycling loop
    when they arrived to the office in the morning.

    Power-cycling the switch got us up-and-running again.

    The IP phones are fine, but I believe the power-cycling may have led to
    the premature failure of one of our POE wireless access points.

    Assuming it might have something to do with the firmware,
    I reverted back to the previously installed firmware of V2.60(AAHO.3)

    Will advise if we see any further power-cycling issues.


  • Zyxel_Jason
    Zyxel_Jason Posts: 371  Master Member
    Hi @TiggerLAS,

    Your symptom description is different from the original poster's and we didn't receive the sane report from other customers recently either.

    Therefore, please let me check the following with you first:
    1. How many IP phones and APs are connecting to your Switch?
    2. Were your APs also rebooting at the same time when IP phones were? 
    3. Did you notice that if all IP phones rebooted at the same time or actually one after one?
    4. Have you ever changed the PoE related configuration? (Not using default setting)

    Thanks.

    Jason
  • TiggerLAS
    TiggerLAS Posts: 63  Ally Member
    edited December 2021

    1.)  There are probably 12, maybe 14 IP phones, and 1 (former) UniFi AP AC Pro.

    2.)   Couldn't tell you if the access point was rebooting at the time;
           but since every phone in the office was power-cycling, it's probably a safe bet.

    3.)   All of the phones were simultaneously shutting off, then powering back up
           for a second, perhaps two - just long enough to flash the LED indicators on
           every phone in the office at what appeared to be the same time, and then off again.

    4.)   I can already rule out any firmware updates for the phones.
           (They wouldn't have been concurrent.)

    5.)   I can also rule out any issues with the phone controller,
           as there are phones on other switches that didn't experience any problems.

    6.)   The POE configuration hasn't changed from default.

    7.)   All phones are currently up and running normally.

    When operating normally, POE usage on that switch is about 37 watts,
    which is less than 25% of the available 170 watt budget.

    I initially thought that perhaps the failed POE access point was the source of the problem,
    but if there is a faulty POE device on the switch, I would assume that there would be
    some sort of protections in place to prevent it from drawing enough power
    to affect the other POE ports.

    Further, the access point itself was working after both of these episodes,
    and ultimately failed within 24 hours of the 2nd occurrence of power-cycling.

    So, I can't really determine if the failure of the AP failure had a causal relationship
    with the power cycling problem, or if its failure was merely coincidental.

  • Zyxel_Jason
    Zyxel_Jason Posts: 371  Master Member
    Hi @TiggerLAS,

    I will PM you for helping us collecting the logs.
    Please help to check your inbox on community.

    Thank.

    Jason