Zertifikat wird im Browser nicht erkannt

Options
Mike2301
Mike2301 Posts: 9
edited May 21 in Wireless
Hallo miteinander,

Bin mittlerweile am Verzweifeln bei Versuch den Browser dazu zu bringen das Zertifikat des NWA55AXE zu akzeptieren so daß da links oben in der Browserleiste nicht mehr "nicht sicher" steht. Selbstredend habe ich das Zertifikat am Rechner importiert (WIN10)

Kann mich bitte jemand von Euch anleiten in welchen Schritten das zu bewerkstelligen ist?

Danke schon mal vorab für hilfreiche Hinweise zu Erfolg B)

Best Answers

  • Zyxel_Joslyn
    Zyxel_Joslyn Posts: 360  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    Answer ✓
    Options
    Hi @Mike2301

    The browser still used the default certificate to communicate with AP.
    As I mentioned before, please go to Configuration > System > WWW > Service Control > HTTPs, and change the "Server Certificate" to NWA55AXE that you created.


    Joslyn
  • Mike2301
    Mike2301 Posts: 9
    Answer ✓
    Options
    Hi Joslyn,

    We hit the target =)

    I thought this is already the IP-Adress and had no knowledge about where to look what Certificate is in use.

    Thank you very much to solve my Problem which tooks me Days.

    i give you and all other Readers here some mor Screenshoots because i think i´m not alone with that issue ;)

    Thanks in advance Joslyn and nice greetings from Austria (EUROPE).


«1

All Replies

  • Zyxel_Joslyn
    Zyxel_Joslyn Posts: 360  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    Options
    Hi @Mike2301

    The browser only can recognize the certificate which is signed from the third-party certificate complany. The default certificate of the AP is a self-signed certificate. That's why the browser will show the warning message even though you have already installed the self-signed certificate into the PC. If you want to let the browser trusts the AP WEB page, please purchase the certificate from the third-party then installing.

    Joslyn
  • Mike2301
    Options
    Okay understood, thank you.
  • Zyxel_Joslyn
    Zyxel_Joslyn Posts: 360  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    Options
    Hi @Mike2301,

    Provide a solution for you.
    We have to import the certificate with the AP IP address into the browser.
    Step 1. Create a certificate with IP address

    Step 2. In the browser, go to Security and Privacy > Security > Manage certificates.

    Step 3. Choose Trusted Root Certification Authorities tab and press import button.
    Ensure the certificate store at "Trusted Root Certification Authorities"

     After finishing the importing, reopen the browser. It will show the connection is secure.


    Joslyn
  • Mike2301
    Options
    great, will give it a try and let you know later :)

    Regards - Mike
  • Mike2301
    Options
    hmmm, it seems that´s what i did before but anyway i must have a mistake inside because it shows still unsecure :(

    what i did....

    first i create a self signed Cert

    Step 2. Export and save to a Folder

    Step 3. Import the Cert from last Folder with self Cert


    Step 4. got Security Warning




    Pressed OK and Success Window appears


    Restarted Browser and got this



    Please tell me what was wrong here ?
  • Zyxel_Joslyn
    Zyxel_Joslyn Posts: 360  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    Options
    Hi @Mike2301

    Did you try to open the WEB page with new incognito window?
    There might be a cache in the browser.
    If it still does not work, please import the certificate into the trusted root certificate in the PC and observe if it works.

    Joslyn
  • Mike2301
    Mike2301 Posts: 9
    edited January 2022
    Options
    Hi Joslyn,

    i´m really abset because i can´t get i work :/

    what i did now:
    first i have to say i was using windows 10 home edition.
    at one point i was not able to open "Group Policy Object Editor".
    i tried other Tools but did not got that thing ready.
    so i graded my windows up to Win10Pro version to get this Policy Editor.
    i did all the steps as shown in the Video but same result in te webbrowser.
    and shure, i used inkognito mode.
    anymore ideas for me Joslyn?
    Kind Regards - Mike



  • Zyxel_Joslyn
    Zyxel_Joslyn Posts: 360  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    Options
    Hi @Mike2301

    Did you change the server certificate to the one that you created?
    Configuration > System > WWW > Service Control > HTTPs, and change the "Server Certificate" to the one that you need.


    If it still does not work, please provide me the certificate detail for me.


    Joslyn
  • Mike2301
    Options
    Hello Joslyn, no there is still the IP-Address as before.
    I see no need to change it. Am i right there or is something new needed?

    nice Greetings - Mike
  • Zyxel_Joslyn
    Zyxel_Joslyn Posts: 360  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    Options
    Hi @Mike2301

    May I know if you change the server certificate to the IP address in WWW?
    If you changed and it still did not work, please show the browser certificate for me.
    Enter the IP address and clieck the "Not secure". Then click the "Certificate is not valid" to show the certificate information.

    Please provide the certificate information for me. I want to know which certificate that the browser used to communicate with the AP.

    Joslyn