Zywall USG100-Plus, Where to find the Firmware, Restarting every 15 minutes

edited January 2022 in Security
Hello All,

In December-2021 we bought a Zywall USG100-PLUS firewall VPN router, it worked fine for 10 days, after that it started to restart on its own every 15 or 20mins, I don't know what is the issue, also thought to update the firmware, but I am not able to find the firmware for the Zywall USG100-PLUSS, please do help me to resolve this issue, thanks in advance.

All Replies

  • k1601
    k1601 Posts: 8
    First Anniversary Friend Collector First Comment

    I have a problem with update my USG-100Plus from this post. When I try to update firmware from 3.30(AACV.7)ITS-WK28-r72114 to the "USG 100-PLUS 330 AACV v3.30P9 (WK48)" process stopped.

    On the console displays:

    [Update Filesystem]
            Updating Filesystem

    and rotated slash.

    At this stage (slash rotated) very long time (one week) without any others actions. I was able to interrupt it only by turning off the power, after which the device does not boot with the message on the console:

    FLASH: AMD 16M

    BootModule Version: V1.17 | 12/01/2011 05:20:17
    DRAM: Size = 256 Mbytes

    Kernel Version: V2.6.25.4 | 2016-07-14 09:27:45
    ZLD Version: V3.30(AACV.7)ITS-WK28-r72114 | 2016-07-14 10:14:06

    Press any key to enter debug mode within 1 seconds.

    BM cmd line: console=ttyS0,115200 root=/dev/ram init=zyinit "-r /dev/sda", address: 0x100000

    Uncompressing Linux...done.
    Start to check file system...
    /dev/sda2: 26/17352 files (3.8% non-contiguous), 16993/69296 blocks
    /dev/sda3: 152/41120 files (28.9% non-contiguous), 45664/163841 blocks
    mount: wrong fs type, bad option, bad superblock on /dev/loop0,
           missing codepage or other error
           In some cases useful info is found in syslog - try
           dmesg | tail  or so

    Kernel panic - not syncing: Attempted to kill init!

    I can restore the device via flashed the database only (firmware restore didn't help). After the restoration the device works normally with the all my old settings.

    I tried hardware reset device before upgrade - it didn't affect. What could be the reason and how can I flash the device?

  • shani
    shani Posts: 4
    First Comment

    exact same issue with mine too. had to recover older firmware. any solutions?

  • Zyxel_Kevin
    Zyxel_Kevin Posts: 797  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @shani

    Greeting Forum, Please kindly try to hardware reset.

    Also we recommend that you replace your appliance due to security issues and performance concerns as USG100 has been end of service for a while.

    Thank you

Security Highlight