GS1920-8HPv2 - SYS LED always off

sunfire
sunfire Posts: 3
Hello,

I have a GS1920-8HPv2 switch where the SYS LED never turns on.
The internal power supply works perfectly, the switch is not discoverable by the Zyxel One Network (ZON) utility. 

I saw the switch has an internal header for a serial console, but the related integrated circuits have not been installed on the PCB.

The switch doesn't have any warranty (I got it from a friend who was looking to throw it in the dumpster).

Is there any way to recover the switch other than full reprogramming of the internal flash memory with an external programmer ?

I do have several external programmers which could write the internal flash memory, but I would need a complete dump from a working switch. Or maybe Zyxel support can provide me with such a dump ?

Thank you very much in advance and best regards,
Sorin

All Replies

  • Zyxel_Melen
    Zyxel_Melen Posts: 227  Zyxel Employee
    Hi @sunfire,

    May you share a video or a photo to show us the SYS LED status?
    It is strange that the SYS LED never turns on.

    And if you want to recover the switch, you may check this topic:

    Why does the Zyxel Switch's SYS LED blink constantly?

    This topic show you how to recover the device firmware if your switch firmware have been corrupted.
    To do firmware recovery, you need a 4-pin console to connect our switch console port which is in the right side of the switch.

    Melen
  • sunfire
    sunfire Posts: 3

    I took two pictures of the switch, the 1st picture is showing the switch with the SYS LED always off, the 2nd picture is showing the console port header on the right side of the switch.



    The SYS LED never turns on regardless how many times I unplug the power cord and plug it back, or how long I leave the switch with the power cord plugged it. The LED itself works ok, I already tested it.

    To connect to the serial console port I used a Prolific USB serial (with a genuine PL2303 chip) but the console always remains blank, no matter what speed settings I chose. I did trace the two middle pins of the console header (one of them is RX, the other is TX, the pin at the bottom is GND, the pin at the top is wired to +3.3Vcc) and both of them arrive up at the pads of that unpopulated SMD integrated circuit above the console header. This leads me to believe the GS1920-8HPv2 switch may not actually have all the parts needed for a fully functioning serial console port. Or maybe the serial console is disabled by the firmware while the switch boots. Or maybe the firmware on the switch is corrupted enough that not even the console works (maybe the bootloader is corrupted ?). Or maybe my switch has a broken CPU.

    I noticed the heatsink is not sitting perfectly on the CPU (there is a gap between the CPU and the heatsink), however, I haven't seen excessive heat marks on the PCB under the CPU, or on the thick thermal pad which sits between the PCB and the metallic case, under the PCB.

    At the moment I think there is some problem with the CPU or the firmware is corrupted.

    Best regards,
    Sorin







  • Zyxel_Melen
    Zyxel_Melen Posts: 227  Zyxel Employee
    edited April 7
    Hi @sunfire

    May I know have your try both side of the console?
    If yes and the SYS LED is still off the console still not print any logs, the switch might have hardware issue.
    I suggest to send this switch to RMA-process.
    You can submit the request here:
    Zyxel Support Campus EMEA

    Melen
  • sunfire
    sunfire Posts: 3

    I did try the console connection both ways for the middle pins (they are the RX and TX pins) and the console always remained blank, regardless of the serial speed I used. The SYS LED always remained off.

    I am not the original owner of the switch, the original owner wanted to throw the switch in the dumpster. I wanted to save the switch from the e-waste shredder by fixing it if possible (I hate recycling electronic stuff if it can be repaired). As far as I know the official warranty policy only covers the original owner of the switch (which I'm not).

    I still want to repair the switch, with the risk of permanently destroying it, but I would need a full firmware image which I could program on the flash chip with an external programmer. Do you know where I can get this please ? Maybe Zyxel support guys can compile one such image for me ? I took a picture of the serial numbers/MAC addresses listed on the underside of the switch (I speculate they need to be hard coded in the firmware).



    Best regards,
    Sorin
  • Zyxel_Melen
    Zyxel_Melen Posts: 227  Zyxel Employee
    Hi @sunfire,

    Since the console didn't print any log, the switch's CPU might had issue, please feel free to submit the RMA request.
    I had ask our RMA team, there's no warranty policy that only covers the original owner of the switch.

    In addition, the recovery firmware can be found in the firmware file we provide in our website.
    Here is the link, please find the 470ABXXXX.rom file and follow this topic to recovery firmware:

    Why does the Zyxel Switch's SYS LED blink constantly?


    Melen