ZLD 4.x failing report send (SMTP) is logged?

mMontana
mMontana Posts: 637  Guru Member
USG40, Firmware 4.71. Working "correctly".
Using SMTP server (port 465, SSL/TLS) for delivering reports. Which never ever worked.

The mailbox/mail service (NOT GOOGLE) works fine for a lot of other devices, but my dear Zyxel firewall seems not willing to cooperate.

No log entry for any kind of troubleshooting.
Email address contain only @ and . as special characters. Other special characters are into password, even as first one.

As already said, the system works fine for other devices (printers, backup services, etc etc).
Most concerning part is that not ever a row in log is fired when i ask "send report now".

All Replies

  • Newbie suggestion here, but have you tried contacting your ISP to verify the SMTP settings, maybe even ask if they can set up a log to monitor for unsuccessful attempts to use their SMTP server ports?
  • mMontana
    mMontana Posts: 637  Guru Member
    edited April 27
    Hi @smb_corp_user well... I used the same account for 40 computers backup notifications (two different softwares) 25 between printers and MFPs... therefore I'm quite confident to manage the various options for the correct use of the service.
    The same mail provider (which currently is not an ISP) was configured almost 200 times into computers.

    Anyway...
    As issue title, my question is "it's possible that faling to send the SMTP report do not fire even one row into USG's log?"
     :) 
  • mMontana
    mMontana Posts: 637  Guru Member
    Update...
    https://community.zyxel.com/en/discussion/1834/issue-with-send-log-by-email
    following this topic i managed to have the messages sent.
    But.

    What the heck is used for System -> Notification SMTP setting???
  • Thanks for the reply and added details. I suppose you could test the previous firmware version, just in case that is something that used to work, but no longer does. Things like this happen from time to time.
  • mMontana
    mMontana Posts: 637  Guru Member
    edited April 29
    Honestly verifying into previous versions (IDK if currently i can roll back to 470 on that device) is non interesting to me, also because I have to schedule double downtime (reboot to 4.70, test, verify that settings are not messed, reboot to 4.71) and into production environment it's quite complicated currently. A firmware without patches has sense only if I'm having issues of any kind.

    Still most interesting part: no error on GUI, no error into LOG. This puzzles me quite a lot.
  • Zyxel_Cooldia
    Zyxel_Cooldia Posts: 929  Zyxel Employee
    edited May 3
    Hi @mMontana,
    The error message is indeed not clear to us, i will proceed to raise this to modify the wording for better clarity.

Security Highlight