GS1900-24EP Logs Me out in 2 seconds.

n5hzr
n5hzr Posts: 13
edited August 26 in Switch
I've been fighting with a new GS1900-24EP switch all day. It has the 2.7 firmware that's not available to download on the website. The 2.7 firmware works OK for a couple of logins, but then it will log me out quickly (in less than 2 seconds) every time I log in subsequently. This makes it impossible to connect to. The only thing that seems to clear the problem is powering off the device. (not a good thing for a production switch) 
I can see that the page is set to refresh every five seconds (that's dumb) as the screen blips by. 
The result is the same on Edge and Chrome...
Is there a way that I can stop that refresh that logs me out?
I tried versions 2.6 (3) and 2.6(4) and they don't do this. However, using those two software versions the PoE doesn't work.

Help?!?!

«13

Comments

  • Zyxel_Chris
    Zyxel_Chris Posts: 579
    Zyxel Certified Network Administrator - Nebula Zyxel Certified Sales Associate 50 Answers 500 Comments
     Guru Member
    @n5hzr,
    Does the firmware 2.70 patch 0 or patch 1?

    I have tried to reproduce this issue with firmware version 2.70 unfortunately, I did not see the issue, can you provide the specific step that I can try to follow.
    On the other hand, please collect the tech support file and private message me.

    Chris
  • n5hzr
    n5hzr Posts: 13
    Chris, thanks for the message. 
    I believe this is patch 0. I'm working remotely on that machine right now, and it still won't let me in. I'll need to visit the site later today to reboot the switch. And, since I can't get into the machine I can't get the tech support file until I reboot.

    The steps for me to reproduce are: 
    1. power on the switch.
    2. log in to the switch a 'couple' of times.
    3. At some point the switch starts automatically logging me out, right after I log in.

    I'll capture a video of the auto log-out sequence before I reboot the switch.

    Thanks - Mark
  • n5hzr
    n5hzr Posts: 13
    I was able to power cycle the switch and I can now access the web management system.

    I have verified that this is using V2.70(ABTO.0) software.

  • n5hzr
    n5hzr Posts: 13
    Chris, I have sent you a DM with the Tech Support info from that switch, and here is a link to a video that I made. This shows the switch login, and then the immediate log-out. OneDrive Video
  • n5hzr
    n5hzr Posts: 13
    Chris, there's something in the webpage that's triggering a refresh every 3 seconds.
    When I set the refresh rate to None or 30 seconds, the page still refreshes every 3 seconds. The data on the page (CPU usage) will respect the refresh data entered, (ie. it will not update the data, or it will update it every 30 seconds, based on the information entered), but the icon at the top of the page refreshes every 3 seconds.

    My guess is that when this goes 'bad', that refresh causes the page to log out.
  • n5hzr
    n5hzr Posts: 13
    I took a look at the Javascript code and here's the reference to the 3 second (3000 millisecond) refresh time...


    function pageRefresh(){
        document.getElementById('switchStatus').contentWindow.location.href = "/cgi-bin/dispatcher.cgi?cmd=257"
        window.setTimeout("pageRefresh();", 3000);
    }

  • n5hzr
    n5hzr Posts: 13
    I noticed something else. In an attempt to configure everything, I clicked through all of the menu items. At some point, the webpage started responding with 'non-edit displays' of the data. It was as if I had become a 'user', instead of an admin. After clicking about 10 items, the system logged me out and displayed the login page.

    I was able to log back in and I checked the users information. I only had the one admin account. I added a user account and an additional admin account to see if that would help me during the next 'auto-logout' event.

    Thanks - Mark
  • n5hzr
    n5hzr Posts: 13
    Here's a copy of the 'non-edit displays' that showed up again. 

    I hit the page refresh button on the web page and it flipped back to the proper 'edit display' like so. (without logging back in)



  • n5hzr
    n5hzr Posts: 13
    One last follow-up. I went through each parameter and 'saved' each setting. My hope was to reset whatever ailed us. The only change I made was to set the inactivity timer to 30 minutes. I have verified that the inactivity timer triggers at 30 minutes. And, subsequent to this morning's power cycle, I have not seen any trouble (except for the 'non-edit display' wierdness) 

    I'll follow up if I see any future craziness.

    Many thanks - Mark
  • Zyxel_Adam
    Zyxel_Adam Posts: 252
    Zyxel Certified Network Administrator - Nebula First Comment First Answer Friend Collector
     Master Member
    Hi @n5hzr,

    Please check your inbox message, we would like you to try if the newer firmware fixes the issue.
    Adam