NWA50AX - connected devices do not get IP from router

Hi Community,

First timer here!  Setting up my home network (see underneath) I found that the devices connected to the WiFi SSIDs do not get IP from the ranges the router should be using.  I have tried searching the forum and reading the manuals (router, switch and NWA50AX) but drawing blanks.  Any help will be more than welcome.

Setup:
Router (pfSense) with 2 VLANs 10 and 99 -> Switch (GS1200-8) -> WAP (NWA50AX)

- Router set as DHCP server.  VLAN 10 DHCP server for 10.10.10.0/24; VLAN 99 DHCP server for 10.10.99.0/24
- Switch set as DHCP client. 
- Switch has port 3 enabled and set for tagged VLANs 10 and 99 (orange for both, grey for VLAN 1).  Port PVID set to 99 for untagged data.
- WAP set as standalone, managed via web interface
- WAP set to be assigned IP address from the system (e.g. the router - and it does get it!).
- WAP has two SSIDs set up, one associated to VLAN 10, the other to VLAN 99.

Symptoms:
When connecting to any of the 2 SSIDs the device gets the same IP, regardless of SSID, and outside the subnet from the VLANs or even the subnet the WAP is in (10.10.1.0/24)

In the pfSense router the ARP table shows both switch and WAP in the right subnet - 10.10.1.0/24 but nothing connected to the WAP. 

Troubleshooting:
I have set another port for VLAN 10, set as untagged and PVID 10 so I can connect a PC directly to the switch.  This PC gets an IP in the range set for the VLAN 10 as it should, and it able to access the devices in the subnet 10.10.10.0 and 10.10.1.0 (as at this point I have not restricted that in the router yet, this is, from this port I can access the web admin pages for pfSense, switch and WAP in the 10.10.1.0 subnet)

QUESTION:
- Is the NWA50AX able to pull IP addresses from the DHCP server of the VLAN? (somewhere I read it is possible if using Nebula, but I have not found information regarding stand alone web setup).
    - If so, what am I missing? :smile:
    - If not, is there a way for getting IPs for each VLAN from the DHCP server in the router?

Thanks in advance for the help! :smiley:

NOTE: I am still learning regarding subnets so this may be a very simple question for experts but it is a hard one for me :smile:

All Replies

  • Pirulito
    Pirulito Posts: 3
    Quick update

    The WAP was in Root AP mode.  Reverting to AP mode solved the IP issue.

    However, I'd like to set a mesh with a second WAP, same model NWA50AX.  I believe that the best way is setting one as Root AP and the other as Repeater.

    Follow up question - In order to build the mesh:
    A) shall I set both WAP in AP mode and wire to the switch?
    B) shall i set one as Root and the second as Repeater? 
    C) other cogitation
    If either B or C is the preferred option, I'll set a new question in the forum to seek advice on sourcing IPs from the router.

    Thank you all in advance
  • Zyxel_Bella
    Zyxel_Bella Posts: 300  Zyxel Employee

    Hi @Pirulito

     

    Welcome to Zyxel community!

    After reading your second description, we could draw your topology as below, please correct me if any misunderstanding.

     

     

    Firstly, could you confirm the AP firmware version is upgrade to latest V6.25 Patch10 that fixed some mesh issue already? Since you told that when AP services in AP mode, clients get IP without problem but it doesn’t when in mesh mode. We assume your configurations of DHCP and corresponding interfaces are correct.

     

    Other possible can go wrong may be the mesh settings are correct or not yet up to date on APs but uplink of repeater is unplugged so the mesh can’t build up successfully.

     

    > Create the WDS profile at Configuration > Object > WDS Profile > Add/Edit

    > Apply the WDS profile to radio settings at Configuration > AP Management > WLAN Setting

    > OP Mode select ‘Root AP’ (on Root AP) or ‘Repeater’ (on Repeater) then select the created WDS profile

    > Wait 2 mins for configurations up to date, remove the uplink of repeater. You can check the WDS link status at Monitor > Wireless > WDS Link Info

     

     

    We’ll help to check if you still have problem, hope you will resolve soon.

    Thank you

     

     

    Regards,

    Bella

     


  • Pirulito
    Pirulito Posts: 3
    Thanks @Zyxel_Bella!  That's what I am trying to set (or failing that both WAP hardwired to the Switch.

    I have just updated to the latest Firmware (previous one was from 2021).  I will do some testing this weekend and report back.