WiFi users cannot access internet / Slow WiFi (USG40W)

Horia
Horia Posts: 33  Freshman Member
Friend Collector First Comment
edited April 2021 in Security
Hi,
I have a quite urgent question, so thank you in advance if you can give me a clue! :'(

On my USG40W I can use internet normally, by connecting via LAN cable.
The Wifi is turned off.
Now as  we will have guests with wifi only devices, I setup the wifi connection of the zyxel USG40, by using the automatic wizard (in the "easy mode").
I tried "normal wifi" (with access to local devices) and "guest wifi".
Both allow to devices to connect, but they do not allow access to the internet.

What could I do? I am no firewall/router specialist, and I have no clue where to look for the settings regarding internet connection of the wifi-users...

As I leave today, and have to leave the WiFi working, I am in a great hurry...

Accepted Solution

«1

All Replies

  • Horia
    Horia Posts: 33  Freshman Member
    Friend Collector First Comment
    in the meantime, the WiFi works! I do not know at all why.
    I just restarted the USG40W, and nothing else.

  • [Deleted User]
    [Deleted User] Posts: 118  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    Probably you are missing a rule like below in the policy control for the guest "zone"
     This allows the guests to go out on the internet
  • Horia
    Horia Posts: 33  Freshman Member
    Friend Collector First Comment
    Hi Mark! thank you very much for your fast reply! I will use this info in case the acces will not work well!
    Please tell me, where is the menu for the policy control? (sorry for the stupid question...)

  • Zyxel_Stanley
    Zyxel_Stanley Posts: 1,366  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Hi @Horia

    You can check all of policy control rules in export mode.

  • Horia
    Horia Posts: 33  Freshman Member
    Friend Collector First Comment
    edited July 2018
    @Stanley, thanks a lot!
    I am going through them.

    I have another problem now: users can connect to the internet, but the connection is slow, or drops, and it feels like the range of the USG40W is weaker and smallet than the normal local internet wireless modem, located in the same place (which has not two antennas and is nothing professional - a usual cheap Thomson...)

    What can I do to improve speed of the wireless connection? And how can I improve the signal?

    I read that I should change the "session control" / "sessions per host". I changed the default 1000 wirh 4000. The users have a lot of apps on their devices, which, I presume, try all in the same time various connections, including peer to peer (whatsApp, etc.)
    But this "sessions per host" does not seem to be a strictly wireless setting. The internet works well over LAN, it has lags only over wifi... On the other hand, laptops and desktops do not have that amount of apps doing peer to peer sessions and multiple threads...

    I also see that the "LAN outgoing" policy includes scanning for viruses. Can this delay a lot the traffic?
  • Zyxel_Stanley
    Zyxel_Stanley Posts: 1,366  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Hi @Horia

    Welcome to Zyxel Community. :)
    On USG40W local AP is support for 2.4Ghz band. It may have many  interference if there is other APs or Bluetooth signal in the environment.
    May we know how about your test result by SpeedTest? (http://www.speedtest.net )
    And also you may use WiFi signal scanner tool(e.g. inSSIDer) to scanning your wireless environment if there are many interferences.

  • Horia
    Horia Posts: 33  Freshman Member
    Friend Collector First Comment
    Thank you, @Zyxel_Stanley !
    I will revert with all necessary details, in about two days, when I will have again access to the firewall.
  • Horia
    Horia Posts: 33  Freshman Member
    Friend Collector First Comment
    edited July 2018
    Hi Stanley,
    I have the following problems with the WiFi of my USG40W:

    - there is an important lag in the wifi connection, showed by TTL times of up to 100ms and package losses, every few seconds happening. If they do not happen, the times are normal (1-4ms). Sometimes I have also no ping response (timeouts when pinging, packages lost)

    - I tried to reposition the USG, to move away from other electronic devices, electrical plugs, etc.

    - I have no other WiFi or bluetooth emittors around

    - the LAN connection to the same USG40 is perfect, no lags

    - the speedtest is good. However the speedtest does not show what happens in momentary situations, but only a global download speed. The only thing that shows the problem is pinging the USG40 router.

    - there are a lot of other wifi emittors from the neighbouring houses, but as we are in a standalone house, the difference of signal between them and us is high (-80 db theirs, -38db ours)

    - the best signal I get, is only -28db, next to the router. 3m away in the same room, it is already -42db

    - I chose a channel that is less crowded

    - I also tried to let the USG manage the channel choice (no difference to the manual version)

    What can I do? Does zyxel have a guide of debugging for this kind of situations? I read in the web that (not specifically for zyxel) there are often such cases with lagging wifi connections.

    As the client has almost no LAN devices and only mobile wifi devices (mac laptops, ipads and iphones), he is complaining in a justified way that he has very slow web connections.

    Thank you in advance!


  • Zyxel_Stanley
    Zyxel_Stanley Posts: 1,366  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @Horia

     

    As you mentioned the speedtest is good. But still very slow in web connections.

    (1)  You can make sure DNS configuration first.

    Configuration > System > DNS > Domain Zone Forwarder.

    You can add a additional DNS to public DNS server.

     

    (2)  And un-limit session control function.

    Go to Configuration > Security Policy  > Session control > Disable session limit function.


  • Horia
    Horia Posts: 33  Freshman Member
    Friend Collector First Comment
    @Zyxel_Stanley
    Thanks a lot for your answer!
    I already had extended the Session Limit from about 2000 (standard setting) to 6000. So this should not be a problem.
    I will add the DNS.

    The main problem is one of hardware, I'm afraid!
    as I wrote, there is a lag in the wireless communication only (not in the LAN)), solely between the mobile device and the router. Pinging the router brings very variable times (from 2ms to 1000ms), with median values of about 30ms. Also, low signal, -42db at only 3meters away from the router (same room, sight connection). So it is not a matter of DNS or other things related to the outside internet, but they are related to the intranet, and the communication between the radio station of the router and the mobile divece.
    Please, what can be done in this case?

    I think of asking Zyxel for replacement of the item we have (as we are in warranty time).

Security Highlight