L2TP VPN not working on IoS with DDNS?

Options
Ensto
Ensto Posts: 20  Freshman Member
First Anniversary 10 Comments Friend Collector
edited August 2022 in Security
Hi.

I just got DDNS for my business dynamic IP. Everything work flawless as before exept one thing.

None of my Apple devices can connect to L2TP anymore... How can this be when the windows computer connects (with built in VPN client in Win 11) without issue on the same L2TP setup? Is it not possible for ios devices to connect to L2TP with DDNS? I even ran the Wizard and created a fresh L2TP config but with the new DDNS name. Everything else like passwords, key types is exactly the same as before i had DDNS.

I have a USG FLEX 100, firmware V5.31(ABWC.0)

I have no clue what casuses the problem.


IKE log:

Accepted Solution

  • Ensto
    Ensto Posts: 20  Freshman Member
    First Anniversary 10 Comments Friend Collector
    Answer ✓
    Options
    Ensto said:
    Hi.

    I just got DDNS for my business dynamic IP. Everything work flawless as before exept one thing.

    None of my Apple devices can connect to L2TP anymore... How can this be when the windows computer connects (with built in VPN client in Win 11) without issue on the same L2TP setup? Is it not possible for ios devices to connect to L2TP with DDNS? I even ran the Wizard and created a fresh L2TP config but with the new DDNS name. Everything else like passwords, key types is exactly the same as before i had DDNS.

    I have a USG FLEX 100, firmware V5.31(ABWC.0)

    I have no clue what casuses the problem.


    IKE log:

    PeterUK said:

    On my android phone they are trying/have removed L2TP IKEv1 support so you may have to setup IKEv2


    mMontana said:
    Do iOS/Apple devices resolve correctly the ddns hostname with the updated ip address?
    Were Apple devices update before the issue?
    I finally found out what the problem was. It was due to the Wizard wich had setup the VPN Gateway Local ID Type as ''DNS'' with my DDNS domainname istead of IP4v and 0.0.0.0 under VPN Gateway>Authentication>Advanced. It seems like the Win 11 native VPN client can figure this out but not the ios native VPN client  :o

    After i changed from DNS to IP4v (0.0.0.0) the ios devices started connection again. I was fooled by the Wizard once more  ;)

All Replies

  • PeterUK
    PeterUK Posts: 2,758  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited August 2022
    Options

    On my android phone they are trying/have removed L2TP IKEv1 support so you may have to setup IKEv2


  • mMontana
    mMontana Posts: 1,302  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited August 2022
    Options
    Do iOS/Apple devices resolve correctly the ddns hostname with the updated ip address?
    Were Apple devices update before the issue?
  • Ensto
    Ensto Posts: 20  Freshman Member
    First Anniversary 10 Comments Friend Collector
    Answer ✓
    Options
    Ensto said:
    Hi.

    I just got DDNS for my business dynamic IP. Everything work flawless as before exept one thing.

    None of my Apple devices can connect to L2TP anymore... How can this be when the windows computer connects (with built in VPN client in Win 11) without issue on the same L2TP setup? Is it not possible for ios devices to connect to L2TP with DDNS? I even ran the Wizard and created a fresh L2TP config but with the new DDNS name. Everything else like passwords, key types is exactly the same as before i had DDNS.

    I have a USG FLEX 100, firmware V5.31(ABWC.0)

    I have no clue what casuses the problem.


    IKE log:

    PeterUK said:

    On my android phone they are trying/have removed L2TP IKEv1 support so you may have to setup IKEv2


    mMontana said:
    Do iOS/Apple devices resolve correctly the ddns hostname with the updated ip address?
    Were Apple devices update before the issue?
    I finally found out what the problem was. It was due to the Wizard wich had setup the VPN Gateway Local ID Type as ''DNS'' with my DDNS domainname istead of IP4v and 0.0.0.0 under VPN Gateway>Authentication>Advanced. It seems like the Win 11 native VPN client can figure this out but not the ios native VPN client  :o

    After i changed from DNS to IP4v (0.0.0.0) the ios devices started connection again. I was fooled by the Wizard once more  ;)

Security Highlight