L2TP VPN works for one user, another user doesn't

pista Posts: 22  Freshman Member
First Anniversary Friend Collector First Comment
edited April 2021 in Security
Hi Forum!

We have created VPN L2TP, started with one l2tp user, we were struggling with it (mainly for several linux distribution users). Now it works fine for user l2tp in group l2tp_test_group. All necessary servers are accessible (even behind tunnel to AWS).

However once I add another user into this group, or just create brand new user and add into this group. The user can login to VPN via L2TP, has certain IP (till now, everything is good). But once I try to connect to AWS, this connection is not possible. 

I download configuration file and tried search for l2tp user - if there is not somewhere just user l2tp - and result is no, everywhere (connected with l2tp) is l2tp_test_group.

Do you know where the issue may be? 

Thanks a lot!

All Replies

  • Zyxel_Stanley
    Zyxel_Stanley Posts: 1,367  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Hi @pista
    Welcome to Zyxel community. :)

    As your scenario to transmitting traffic to Site to Site VPN tunnel which peer is AWS
    The policy route rule is required.

    And also you can monitor the packets has routed into AWS VPN by outbound field and gets response from peer by inbound field.
    (Monitor > VPN Monitor> IPSec)

  • pista
    pista Posts: 22  Freshman Member
    First Anniversary Friend Collector First Comment
    Hi Stanley,

    I am afraid that you didn't get my point, all these settings are properly set (I believe), the issue is, when I add another user to l2tp_test_group, the connection is not possible.

    The first (original) user in the group is able to connect to AWS but another user is not. The new user is just able to connect into L2TP.

    Would it be possible to describe you all our settings and topology in PM? Just to check, if everything is OK.

    Thanks a lot.

Security Highlight