XGS1210-12 switches with Ubiquiti Access Points and Controller

IanR
IanR Posts: 4
First Comment
I am trying to replace my current 1GBps HP switch with two XGS1210-12 switches for 2.5GBe connectivity.  Apart from the LAG issue for 10GB SFP ports (Which hopefully sounds like there might be a fix), I've now discovered a real problem with my Unifi devices.

I have a Unifi local controller, with 5 Access points; 3 AC-HD, an AC-M outside AP and an AC-LR. these are all wired directly to the switch via PoE injectors and worked perfectly under the HP switch.  However, now connected to the Zyxel switches, the controller no longer can show the network topology, and all the access points are being daisychained via "wired uplink".  it seems that one AC-HD connects directly and all other accesspoints are daisyhcained to each other through this single one.  Its not a config setting on the controller (I have tried everything!) but the problem still exists.  This is causing slowdown across the wifi network, and causes everything to drop when i reboot a single AP.

I have defaulted both zyxel switches, I have all APs connected to the same 1GBps ports on the same switch, have tried disconnecting the SFP+ link between the switches , connecting the APs across different switches, everything.

Clearly something in the switch config is affecting the ability of the APs to talk at the same time, but i can't find what.

Has anyone had this problem and found a fix/workaround?  as the house is full of wireless devices, this is a deal breaker on these switches.


All Replies

  • ivers
    ivers Posts: 43
    First Comment First Answer Friend Collector Fifth Anniversary
     Freshman Member
    @IanR,
    Looks like this is the known issue on Ubiquiti to drew the wrong topology.

    Incorrect topology shown in controller map | Ubiquiti Community
    Unifi topology map showing AP connected to another AP | Ubiquiti Community

    Also, don't think it will lead the traffic down, did you enable mesh on those APs?
  • IanR
    IanR Posts: 4
    First Comment
    Thanks for the reply, yes I know the topology has had known issues for a while; however I have been using an HP Procurve switch for 2 years now and not had a single problem with it - Now I have put the Zyxel switches in there are issues.  I have disabled wireless uplink/mesh/connectivity monitor as everything is hard wired.  I have linked the procurve switch back in and everything works; as soon as I link the Zyxel switch back in and connect any access point to it, that AP disappears from topology and shows as wired uplink to another AP. 
    I do not use wireless uplinks and all meshing settings are disabled.  
  • Zyxel_Chris
    Zyxel_Chris Posts: 590
    Zyxel Certified Network Administrator - Nebula Zyxel Certified Sales Associate 50 Answers 500 Comments
     Guru Member
    @IanR,
    Thanks for your update, since we're not sure how Ubiquiti drew the topology (ex, based on which protocol) maybe the known issue caused this, could you please confirm this part with them?

    On the other hand, you have mentioned the low speed of networking, how did you test it, please share the detailed test step for me, (for instance, transfer file between 2 AP's station) also please let me know the HP switch model name, thanks. 

    Chris