MG-108 upload speed are limited to <400MPS

Options
I am testing the 5G CPE on their mmWave throughput. I need to compare the performance on different PCs. When I use MG-108 the DL speed is perfect. But UL speed only 300+ MPS. My ISP has symmetric traffic flow which support 1G DL/UL. My connection is below:
1. ISP -> MG-108 -> PC 
2. ISP -> PC
Test results are below:
1. DL 900 UL 300
2. DL 900 UL 900

I purchased 2 MG-108 and they behaved the same way. Any idea?

Thanks!
Weite

All Replies

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,748  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    Hi @weitehuang,

    We have experienced some upload decrease cases and solved them by disabling the Green Ethernet Technology (EEE).
    Could you share your MG-108's serial number and the modem's model name with me? 
    Or could you check if your modem supports the EEE function? If yes, could you disable it and test again?

    Zyxel Melen

  • weitehuang
    Options
    Hi Melen,
    Thanks for quick response! Here are my S/N
    1. S224324007867
    2. S224324007861
    My modem is a fiber optic modem (model BGW210 from AT&T/Arris). I browsed the settings but didn't see EEE is supported. Appreciate your help!

    Thanks!
    Weite 
  • Zyxel_Melen
    Zyxel_Melen Posts: 1,748  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    Hi @weitehuang,

    Sorry for the late reply and thanks for your information.
    I will pm you for asking for your contact information so our local support will contact you.

    Zyxel Melen