GS1920-48HP v4.70 VLAN issue

Options
JZeman
JZeman Posts: 3
First Comment
edited January 2023 in Switch
Hello everyone and please give me your opinion on this problem. I am trying to set up a simple input and output VLAN with number 5, but the configuration is misbehaving.

I have a device connected to port 1, untagged port vlan 5. On the output untagged port 45 vlan 5. I set a static IP address on the end device behind the port 45 and the VLAN does not work.

I only found the problem after exporting the configuration. VLAN 1 on ports 1-50 remains untagged even though I have set forbidden VLAN 1 for ports 1+45. If I manually edit the configuration and remove VLAN 1 untagged on ports 1+45, saved config import -> it suddenly works fine. How does this problem arise please? Thank you

Below exported configuration without modifications for correction:

vlan 1
  name 1
  normal ""
  fixed 2-44,46-50
  forbidden 1,45
  untagged 1-50
  ip address default-management 192.168.3.38 255.255.255.0
  ip address default-gateway 192.168.3.254
exit

vlan 5
  name xxx
  normal 2-44,46-48
  fixed 1,45,49-50
  forbidden ""
  untagged 1,45
exit



All Replies

  • PeterUK
    PeterUK Posts: 2,730  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited January 2023
    Options

    The config view is not that clear when it says untagged

    fixed = part of the VLAN

    untagged = if its tagged or untag even if forbidden which if forbidden is forbidden and not part of the VLAN.

    Sounds confusing better to view the GUI

    in your case for:

    VLAN1 

    forbidden 1,45 

    fixed 2-44,46-50 untag

    PVID set to 1 for 2-44,46-50

    VLAN5

    forbidden 2-44,46-50

    fixed 1,45 untag

    PVID set to 5 for 1,45


  • JZeman
    Options
    Hi PeterUK, thank you very much for your response. I have attached some screenshots of the GUI. From the settings it shows that VLAN 1 is set as forbidden on the ports, but in the export it still shows as untagged. Am I doing something wrong please?


    I only expect an untagged port when I set fixed without tx tagging.







  • PeterUK
    PeterUK Posts: 2,730  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    you now need to go to VLAN Port Setup and set port 1 and 45 to PVID 5
  • JZeman
    Options
    This is also done, should i check anything else please?


  • PeterUK
    PeterUK Posts: 2,730  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited February 2023
    Options
    That should be it?  did you mean to set tag on ports 49-50?

    as said the export listing for untagged is not what you think it means