Issue when printing

drouboyboy
drouboyboy Posts: 5
edited April 14 in Security

Hi,

Following VLAN deployement, I'm currently encountering printing issue.

Indeed, on any PCs, jobs stay stucked in spool and are not delivered to printer. The only thing to do is to leave jobs in spool and restart the computer. Once the computer is restarted, jobs are sent to printer.

Below, a diagram of my architecture:


Actual status and tests:

* Any PCs on the same switch, same VLAN, same OS can print and others not. As an example, in our diagram PC01 can but PC02 can't.

* Every PCs can ping printer and access to its web interface configuration.

*As I previously said, when we restart the computer, jobs in spool are sent to printer

* I've tried to disable SNMP check in printer configuration on PCs because printer was seen as disconnected

*I've also tried to disable bidirectionnal mode in printer configuration on PCs

*Print works well when I'm on the same subnetwork (connect to the non manageable switch)

* Below packet trace of a KO printing job


*Below packet trace of an OK printing job


Thanks for your help!

Seb

Accepted Solution

  • drouboyboy
    drouboyboy Posts: 5
    Accepted Answer
    Hi,

    The problem was caused by our antivirus/firewall solution which refused network printing.

    The installer let the user choose if he want to use windows firewall or bitdefender firewall that's why some users were able to print and others no.

    Thanks for your help.

    Seb.

All Replies

Sign In to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click on this button!