Why can't resolve a specific domain after manually add A record

Zyxel_Kevin
Zyxel_Kevin Posts: 892  Zyxel Employee
Zyxel Certified Network Administrator - Security Zyxel Certified Sales Associate 100 Answers 500 Comments
edited May 2024 in Other Topics

Symptom:

After added A record for “xxx.com”, a specific domain cannot be resolved.

For example:

You have record test.zyxel.com

Then you cannot resolve IP address if the record exist.

Root Cause:

If a record is added, it will create a zone called “zyxel.com”. If the CNAME match the zone, this issue will occur.

Workaround:

1)Please add the record manually if you don’t want to change CNAME in Public DNS domain name.

The issue is likely to occur frequently in self-owned DNS domain name or Split DNS domain name.

Reference:

https://www.rfc-editor.org/rfc/rfc1912.txt

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