Blocked connection issue between IoT devices and access points?

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Zyxel_Judy
Zyxel_Judy Posts: 989  Zyxel Employee
First Anniversary 10 Comments Friend Collector First Answer
edited July 2023 in Other Topics

Symptoms:

The Access Point (AP) be configured with multiple SSIDs on both 2.4Ghz and 5Ghz frequencies. Users may encounter a situation where an IoT device, such as a smart TV, is blocked by the AP, causing the IoT device to lose its connection to the AP. A recurring message might appear in the log, indicating that the station is blocked due to Legacy STA Rejection.

Root Cause:

The root cause of this issue could be:

  1. The IoT device is attempting to connect to the 5GHz SSID, but it only supports 2.4GHz. The 5GHz band may not be fully compatible with all IoT devices, leading to the device being blocked by the AP.
  2. “Allow 802.11ax/ac/n stations only function” is enabled, which prevents legacy clients, including 802.11a/b/g, from associating.

Solution:

  1. Create a new SSID exclusively for the IoT device

Navigate to Configure > Access points > SSID advanced settings

  • Configure a new SSID with WPA2 personal security.
  • Select "2.4GHz only" for band mode option
  • Disable 802.11k/v/r.

2. Disable “Allow 802.11ax/ac/n stations only” function

Go to Configure > Access points > Radio settings

Note: Ensure that both the IoT device and the AP are updated to the latest firmware for optimal performance.

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