Some PC can’t connect L2TP VPN if gateway is behind NAT

Options
Zyxel_Kevin
Zyxel_Kevin Posts: 755  Zyxel Employee
First Anniversary 10 Comments Friend Collector First Answer
edited July 2023 in VPN

Root Cause:

This is windows issue.

Workaround:

Log on to the Windows client computer as a user who is a member of the Administrators group.

1)Select Start > All Programs > Accessories > Run, type regedit, and then select OK. If the User Account Control dialog box is displayed on the screen and prompts you to elevate your administrator token, select Continue.

2)Locate and then select the following registry subkey:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent

3)On the Edit menu, point to New, and then select DWORD (32-bit) Value.

Type AssumeUDPEncapsulationContextOnSendRule, and then press ENTER.

Right-click AssumeUDPEncapsulationContextOnSendRule, and then select Modify.

In the Value Data box, type values “2”

4)Restart the computer.

Reference:

https://learn.microsoft.com/en-us/troubleshoot/windows-server/networking/configure-l2tp-ipsec-server-behind-nat-t-device