Issues with single-line LAG with GS1900-24E

Is it possible to operate a LAG with only 1 port as LAG member?

I RTFMed before (checked loop guard and mirror to be disabled etc.) and also in the forums didn't found any related thread. My LAG is not working, I tested with static mode and LACP on both sides.

Background:

I want to perform a smooth migration.
As-Is topology: non-LAG single link between switch GS1900-24E and an OPNSense router (Switch Port 24←→Router Port 3)

To-Be topology: dual link LAG (Switch Ports 24&23←→Router Port 3&4)

For smooth migration, the idea is to leave the single link untouched (Switch Port 24←→Router Port 3), and firstly configure a singe link LAG (Switch LAG1 Port 23←→Router LAG Port 4). Then I can test this LAG by plugging-off the single-link cable (Switch Port 24←→Router Port 3) and plugging-in the single-link-LAG cable (Switch LAG1 Port 23←→Router LAG Port 4).

I configured LAG1 as described above on both ends, and I configured all VLAN settings of LAG1 absolutely identical to Port 24. Unfortunately, the LAG link is not working. That's why I wonder if an LAG with only 1 member port is technically possible.

Best Answers

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,617  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited July 2023 Answer ✓

    Hi @Sumpfstrauch,

    I did a local test that set up single-line LAG with GS1900-24E and found LAG link also did not work. I checked the OPNSense interface overview and found it uses LACP protocol to run LAG. I fixed it by removing it from OPNSense and setting it up again.

    Did you check the interface overview on OPNSense? If the protocol is using LACP, you need to enable LACP on GS1900-24E or remove the setting from OPNSene and set it up again.

    Zyxel Melen

  • Sumpfstrauch
    Sumpfstrauch Posts: 11
    First Comment
    Answer ✓

    Thanks, Melen! It's working now! On GS1900-24E, LACP has to be enabled on two places: In global LAG options and in the config of the concrete LAG. I missed the first one. :-)

    Summary:

    • LAG is working between GS1900-24E and OPNSense router
    • working also with only one member port in the LAG (I used this setup for smooth migration path)
    • LAG is working with static LAG config and LACP
    • for LACP, enable global AND local LACP option on GS1900-24E
    • if the config is not working, try to reboot OPNSense - this did the trick for me in some situations

    Thank you much!

    Holger

All Replies

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,617  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited July 2023 Answer ✓

    Hi @Sumpfstrauch,

    I did a local test that set up single-line LAG with GS1900-24E and found LAG link also did not work. I checked the OPNSense interface overview and found it uses LACP protocol to run LAG. I fixed it by removing it from OPNSense and setting it up again.

    Did you check the interface overview on OPNSense? If the protocol is using LACP, you need to enable LACP on GS1900-24E or remove the setting from OPNSene and set it up again.

    Zyxel Melen

  • Hi Melen,

    oh, thank you so much. I have not expected anyone to do concrete testings about that, that's phantastic - thank you. :-) I already did what you wrote, I tried both: With LACP enabled on both ends and with LACP disabled on both ends. But because you are writing that you succeeded in setting up this type of connection I can give it another try. Maybe I did something wrong with my complex VLAN settings although I always double checked everything. Knowing that it should work in principle is very valuable for me. I will check this out again and give a report here whether it works (incl. some hints for future users) or not.

    Thank you,

    Holger

  • Hi all, hi Melen, hi /me,

    the LAG with only one member port is working now with GS1900-24E and OPNSense router. The clue has been to reboot OPNSense when changing LAG settings, in my case when switching between LACP and static. Just applying the settings didn't work for me.

    My status:

    • link is working with static LAG configured on both ends
    • link is not working with LACP configured on both ends

    Because Melen succeeded in LACP setup as well, I will do some further trials with LACP and add my findings here before closing this topic.

    Cheers

    Holger

  • Sumpfstrauch
    Sumpfstrauch Posts: 11
    First Comment
    Answer ✓

    Thanks, Melen! It's working now! On GS1900-24E, LACP has to be enabled on two places: In global LAG options and in the config of the concrete LAG. I missed the first one. :-)

    Summary:

    • LAG is working between GS1900-24E and OPNSense router
    • working also with only one member port in the LAG (I used this setup for smooth migration path)
    • LAG is working with static LAG config and LACP
    • for LACP, enable global AND local LACP option on GS1900-24E
    • if the config is not working, try to reboot OPNSense - this did the trick for me in some situations

    Thank you much!

    Holger