USG20-VPN FIRMWARE UPGRADE

Options
AC3
AC3 Posts: 2
First Comment
edited August 2023 in Security

Good morning sir,

I tried many times to upgrade my USG20-VPN. My version is V5.30 and i want the last one. I have tried to download the 5.37 firmware and tried to upload it manually : "Firmware upload is always in progress" (i try many times between 30 minutes and one hour waiting), i tried to let the system automatically download it, same message "Firmware upload is always in progress. I tried to download previous firmware 5.31 : same result. I change my internet browser an same result. NEVER ERROR MESSAGE BUT ALWAYS IN PROGRESS. I erase my internet temporary files : same results. Please, can you help me to find the right solution to upload my system ? thanks a lot

All Replies

  • mMontana
    mMontana Posts: 1,342  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    If you are local to the device, consider this procedure:

    • download the correct full file, keep close the serial cable and the procedure for disaster recovery of the firmware. Better in paper or local PDF than anything else
    • access to USG20-VPN and reboot the device via web interface
    • close the browser, start pinging the Firewall IP. Once came alive again, try to login via the browser
    • try to update via automated update procedure your device, then start pinging the firewall
    • take a tea, a soda, a coffee… whatever. Wait
    • I assume than after short time the ping session will start failing, than will begin to work again
    • after several minutes, try to access again to the firewall and check if the version is updated
    • if not, shut down the firewall via web interface, than remove power for at least 1 minute
    • then, start again

    If boot of the firewall fails… you can still use the disaster recovery procedures.

Security Highlight