Import certificate error ATP

Options
aait
aait Posts: 14  Freshman Member
First Anniversary 10 Comments Friend Collector

ATP100, after the new Firmware Version V5.37(ABPS.1) / 2023-11-08 05:27:27 it is not possible to import .p12 certificate

errno: -17011
errmsg: PKI certificate type is not supported.

Accepted Solution

  • Zyxel_Jeff
    Zyxel_Jeff Posts: 1,066  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options

    Hi @aait

    We will merge this fix into 5.37P1 WK firmware, too. It is expected to be released in the middle of January 2024. Thanks.

«1

All Replies

  • aait
    aait Posts: 14  Freshman Member
    First Anniversary 10 Comments Friend Collector
    Options

    even the certificate with the .pfx extension is not imported, "errno: -17011 errmsg: PKI certificate type is not supported".. I have a certificate expiring in two days, how can I resolve this?

  • Zyxel_Jeff
    Zyxel_Jeff Posts: 1,066  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited December 2023
    Options

    Hi @aait

    Thank you for reporting this case to us. Could you provide a remote Web-GUI to us for further checking? We will send a private message to you later, please check your inbox, thanks.

  • dpipro
    dpipro Posts: 64  ZCNE Certified
    First Anniversary ZCNE Switch Level 1 Certification - 2020 ZCNE Nebula Level 1 Certification - 2020 ZCNE Security Level 1 Certification - 2019
    Options

    Hello,

    I'm having the same issue with USG 110, USG40 and USG60 all of them with firmware 4.73 patch 2.

    @Zyxel_Jeff any suggestions?

    Thank you

    Best regards
  • Zyxel_Jeff
    Zyxel_Jeff Posts: 1,066  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @aait and @dpipro

    OK, noted. We are checking it internally.

  • Zyxel_Jeff
    Zyxel_Jeff Posts: 1,066  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @aait

    We will fix it in the next FCS firmware, thanks.

  • aait
    aait Posts: 14  Freshman Member
    First Anniversary 10 Comments Friend Collector
    Options

    Hi Jeff,
    when will the new firmware be released?
    I have several ATP with expiring certificates
    Thank you

  • Zyxel_Jeff
    Zyxel_Jeff Posts: 1,066  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options

    Hi @aait

    We will merge this fix into 5.37P1 WK firmware, too. It is expected to be released in the middle of January 2024. Thanks.

  • Hermes_AT
    Options

    We have an ATP 100W and having those issues with applying our pkcs12 pfx cert bundle. Current Firmware 5.37(ABRW.1)C0 is from November 2023, so I guess that fix is not rolled out yet? Our cert runs out in the next few days.

  • aait
    aait Posts: 14  Freshman Member
    First Anniversary 10 Comments Friend Collector
    Options

    Install patch3, this fixes the certificate import

    https://support.zyxel.eu/hc/en-us/articles/360005438274

    ATP Series 5.37 Patch 3 WK01(2024)

    https://www.dropbox.com/scl/fi/je8unjlxggxmb97y5ba0q/537ABRW1ITS-24WK01-r112173.zip?rlkey=q7rnb1t7vgi322estxwnm4sr9&dl=1

  • dpipro
    dpipro Posts: 64  ZCNE Certified
    First Anniversary ZCNE Switch Level 1 Certification - 2020 ZCNE Nebula Level 1 Certification - 2020 ZCNE Security Level 1 Certification - 2019
    Options

    And for USG Series with 4.73? When the patch will be available? Thank you

    Best regards

Security Highlight