Why is the EX5401 not sending a sip response to 183

when the fxs port on the EX5401 is programmed although it registers and can receive calls it can't make calls due to not responding to sip 183. why is the router not sending a 200 ok to 183?

Accepted Solution

  • tonygibbs16
    tonygibbs16 Posts: 835  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited January 26 Answer ✓

    Hello @drwats1

    ok, are you able to say what firmware version you are running please?

    From my research, if a 183 Session Progress message is received then the calling party should do early media that the caller can listen to any in-band messages or tones.

    the diagram above from https://thanhloi2603.wordpress.com/2017/08/05/sip-180-vs-183-vs-early-media/

    This makes me think that the EX5401 would not have to emit any media in response to the 183 Session Progress message with SDP, but allow in-band media to be received.

    Kind regards,

    Tony

All Replies

  • tonygibbs16
    tonygibbs16 Posts: 835  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited January 26

    Hello @drwats1,

    From some investigation, it seems like SIP message 183 is used for early media in order to have in-band progress messages and tones.

    see https://andrewjprokop.wordpress.com/2014/04/18/sip-media-management-early-media-vs-late-media/

    Can you make any calls to any test number of your voice provider?

    Can you share any logs?

    Kind regards,

    Tony

  • drwats1
    drwats1 Posts: 4
    First Comment

    When a call is made in - all works fine.

    When the call is made out there is no audio outbound from the router.

    Can't share logs I'm afraid

  • tonygibbs16
    tonygibbs16 Posts: 835  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited January 26 Answer ✓

    Hello @drwats1

    ok, are you able to say what firmware version you are running please?

    From my research, if a 183 Session Progress message is received then the calling party should do early media that the caller can listen to any in-band messages or tones.

    the diagram above from https://thanhloi2603.wordpress.com/2017/08/05/sip-180-vs-183-vs-early-media/

    This makes me think that the EX5401 would not have to emit any media in response to the 183 Session Progress message with SDP, but allow in-band media to be received.

    Kind regards,

    Tony

  • drwats1
    drwats1 Posts: 4
    First Comment

    You would think so. The thing that has me confused is that the fault is only present on outgoing calls.

    We know it is something to do with the built-in ATA, as an external ATA works fine.

    Can inband signalling be switched on and off on the router?

  • tonygibbs16
    tonygibbs16 Posts: 835  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer

    Hello @drwats1

    From looking at the user guide at https://spdl.zyxel.com/AX7501-B0/user_guide/AX7501-B0_V5.15-V5.17%20Ed%202.pdf I think that the closest to turning SIP off in the EX5401 would be to disable the SIP ALG (see section 11.5 and figure 135) and to deleting the SIP service provider configuration in the EX5401(see section 4.6.1 and figure 39.)

    This should hopefully allow you to use an external ATA successfully.

    Kind regards,

    Tony

  • drwats1
    drwats1 Posts: 4
    First Comment

    Sorry I may not have explained this properly. For years the zyxel internal fxs port has worked fine.

    Then we start getting no outgoing audio on outbound calls, after a firmware upgrade.

    The SiP ALG is turned off by standard.

    Incoming calls to the fxs port work fine.

    So far all we have from ISP and IP-PBX manufacturer is that the router is not acknowledging 183 with a 200 OK on outbound calls.

    We disable the sip account on the router and install an external ATA and all works fine.

Consumer Product Help Center