GS1900-24E 2.70, 2.80 - Javascript Error

Options

Hi,

with both firmware versions I see Javascript errors in Firefox 122 and Safari 17.3 after login on "dispatcher.cgi?cmd=1" page. This breaks most sidebar options.

The main error is:

"Uncaught SyntaxError: unterminated regular expression literal" line 124

at "if (z[i].name.match(fname) != null && parseInt(z[i].value) == parseInt(s</zalue) )"

Additionally a request to "/css/image/tb_status_20.gif" returns 404. Also the whole interface still renders in quirks mode as the "<!doctype html>" is missing.

All Replies

  • Zyxel_Kay
    Zyxel_Kay Posts: 560  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @admin53531

    I've tried to reproduce the issue using Firefox Version 122.0 (64-bit) on Windows 10, with my switch firmware version being V2.80(AAHK.0). Although I encountered the same error in the web console, the interface displayed as expected on my end.

    To assist you further, could you please provide a screenshot of your web interface? This will help us in conducting a more thorough investigation to address the issue.

    Kay

  • admin53531
    Options

    can't access my workstation right now. Just click on "Monitor" and then "Configurarion" in the left menu.

  • Zyxel_Kay
    Zyxel_Kay Posts: 560  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @admin53531

    Since we were unable to replicate the same issue on our end, it would be greatly helpful if you could provide us with a screenshot or screen video recording of the steps you mentioned - clicking on "Monitor" and then "Configuration" in the left menu.

    This will enable us to conduct a more thorough investigation to better assist you.

    Thank you in advance for your cooperation.

    Kay

  • admin53531
    Options

    just click on "monitor", nothing will happen due to the js bug.

  • Zyxel_Kay
    Zyxel_Kay Posts: 560  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited February 1
    Options

    Hi @admin53531

    We attempted to replicate the issue once more using a MacBook with Firefox 122.0 and Safari 17.3, but unfortunately, we were unsuccessful in reproducing the problem. Attached are screenshots of our web interface taken from different browsers:

    • Firefox 122.0
    • Safari 17.3

    We would greatly appreciate it if you could provide us with a short video recording demonstrating the issue you are experiencing. In the screen video recording, please ensure that the DevTools (F12) is enabled before logging into your web interface. Kindly click on the error messages in the Console and showcase the error details.

    This will help us better understand and address the problem.

    Kay