Zyxel switch does not auto-boot

Zactron Posts: 1
edited August 2022 in Switch
Hi folks,

I have about 90 Zyxel MES-2110 L2 switches amongst my deployed inventory.

I am aware that these have been discontinued, but, they suit my needs adequately.

I am slowly replacing them with Zyxel GS1900-10HPs, but many will remain in place for the foreseeable future.

A number of these MES-2110 switches have exhibited apparent failure after a reboot?

I noticed that the LED function test on the ports was not occurring after applying power to the switch, and, that the 'SYS' LED was not illuminated.

After connecting a PC via the console port, to observe any activity, it became apparent that the switch was in fact still operational, but boot up had paused, and was presenting a menu.

Typing menu option '0', allowed the switch to complete its boot up, and it was then fully operational.

I compared this boot process with another of the switches that was working correctly, and noticed that it had an additional line of boot code which stated something like; 'press 'C' within 3 seconds to prevent auto-start'.

The failed switches do not have this line of code.

How could this line of code have been deleted merely by the switch being power cycled?

More importantly, how can I restore it?

I have tried re-uploading the firmware, and, a saved config file from one of the working switches, but neither act restores it whether I do so from the CLI or the GUI.

Within the latest download files for this switch, are files named; 100BPT2.bin, 100BPT2_bm107.bin and 100BPT2_rom.bin

Would restoring the ROM file fix the issue?

100BPT2.bin I know to be the firmware file... can I safely assume that 100BPT2_rom.bin is the ROM file?

That being the case, what is the purpose of 100BPT2_bm107.bin?

Is there a specific command line instruction to upload the ROM file?

I don't wish to brick any switches by uploading the wrong file if I can help it.

Any guidance much appreciated.


All Replies

  • CarnegieJ
    Have the MAC addresses changed for the MES-2110 switches that have exhibited apparent failure?
  • Zyxel_JonasTan
    Zyxel_JonasTan Posts: 94  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Hi @Zactron,

    Welcome to Zyxel Community!

    Based on the description, if the SYS led is not the blinking after powering the switch.
    The issue is confirmed related to a hardware issue and it doesn't have any recovery solution.
    Having a hardware issue could affect the software with some unexpected issue like booting up will pause and more issue that is unpredictable.

    I would like to inform that MES-2110 is a very old model.
    You may try to restore the switch to factory default settings [System Restart Menu > Restart Option]. This method will also reinitialize the system. Then observe if the issue is solved.
    If the issue still exists, it means that the issue is not related to software.

    We prefer following your plan which is replacing with GS1900-10HP to prevent other service impacts in the network environment. After all hardware issues can't predict what could be the next problem.

    Best regards,