NWA50AX - disconnecting client regularly

Options
azimuthnrth
azimuthnrth Posts: 3
Friend Collector First Comment
edited March 26 in WirelessLAN

Hi to the community!

I have a strange behavior with one of the 20+ clients connected to the AP.

It is disconnected time after time. After reconnecting this laptop to the network, it works again. There is a log related to this certain mac address (mac is changed a bit):

[Mon Mar 25 16:55:30 2024] nl80211: Delete station ac:12:00:00:00:00
[Mon Mar 25 16:55:30 2024] wlan-2-1: Event DISASSOC (1) received
[Mon Mar 25 16:55:30 2024] hostapd_logger_cb: wlan-2-1: STA ac:12:00:00:00:00 IEEE 802.11: disassociated
[Mon Mar 25 16:55:30 2024] wlan-2-1: AP-STA-DISCONNECTED ac:12:00:00:00:00
[Mon Mar 25 16:55:30 2024] hostapd_logger_cb: wlan-2-1: STA ac:12:00:00:00:00 WPA: event 2 notification
[Mon Mar 25 16:55:30 2024] wpa_driver_nl80211_set_key: ifindex=24 (wlan-2-1) alg=0 addr=0x777ae718 key_idx=0 set_tx=1 seq_len=0 key_len=0
[Mon Mar 25 16:55:30 2024] addr=ac:12:00:00:00:00
[Mon Mar 25 16:55:30 2024] WPA: ac:12:00:00:00:00 WPA_PTK entering state DISCONNECTED
[Mon Mar 25 16:55:30 2024] WPA: ac:12:00:00:00:00 WPA_PTK entering state INITIALIZE
[Mon Mar 25 16:55:30 2024] wpa_driver_nl80211_set_key: ifindex=24 (wlan-2-1) alg=0 addr=0x777ae718 key_idx=0 set_tx=1 seq_len=0 key_len=0
[Mon Mar 25 16:55:30 2024] addr=ac:12:00:00:00:00
[Mon Mar 25 16:55:30 2024] nl80211: Set STA flags - ifname=wlan-2-1 addr=ac:12:00:00:00:00 total_flags=0x8 flags_or=0x0 flags_and=0xfffffffe authorized=0
[Mon Mar 25 16:55:30 2024] hostapd_logger_cb: wlan-2-1: STA ac:12:00:00:00:00 IEEE 802.1X: unauthorizing port
[Mon Mar 25 16:55:30 2024] nl80211: sta_remove -> DEL_STATION wlan-2-1 ac:12:00:00:00:00 --> 0 (No error information)
[Mon Mar 25 16:55:30 2024] ap_free_sta: cancel ap_handle_timer for ac:12:00:00:00:00

Firmware V6.29(4) / 2024-01-10 14:07:10

I tried to switch on/off 802.11k/v Assisted Roaming with no result.

I need help to find out what happens with this as it doesn't contain a reason of it.

Any help will be appreciated. Have a nice mood!

All Replies

  • Zyxel_Nami
    Zyxel_Nami Posts: 487  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hello @azimuthnrth

    To look into the issue, could you please specify the type and model of the device that's disconnecting? Ensure its firmware is up-to-date.

    Additionally, for a thorough analysis, we would need the full diagnostic information of the AP. You can send this to us via a private message by clicking on my name and selecting the 'Message' button.

    Thank you.

    Zyxel Nami

  • azimuthnrth
    azimuthnrth Posts: 3
    Friend Collector First Comment
    Options

    Hi Nami, thanks for the response.

    To answer your question, I'd say I know exactly about at least 2 devices: Lenovo Thinkpad with OS Windows 10 as well as HP LaserJet MFP M283fdw.

    To update my experience with it, I turned off WPA3 on the WiFi (switched to WPA2), and it solved the problem at the moment. Anyway, I hope to use WPA3 for security reasons.

    I suspect it might be caused by Win10 incompatibility with WPA3. When I moved to the WPA2 security, all Win 11 laptops reconnected OK, but that Win 10 laptop.

  • AlanM55
    AlanM55 Posts: 2
    Friend Collector First Comment
    Options

    I am having this exact same issue with this exact same make and model AP.

    Every day around 1:30 - 2:30, both my Windows Laptop (HP running Windows 11) and my Wife's HP (running windows 11) will get disconnected.

  • Zyxel_Nami
    Zyxel_Nami Posts: 487  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @azimuthnrth

    Thank you for the update. To clarify, are the Windows 11 devices successfully connecting to the SSID with WPA3? Also, regarding the Windows 10 laptop, does it fail to connect to the SSID regardless of whether it's set to WPA2 or WPA3?

    Please provide us with the diagnostic info via private message that can help in diagnosing the issue more accurately.

    Zyxel Nami

  • Zyxel_Nami
    Zyxel_Nami Posts: 487  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hello @AlanM55

    When the devices disconnect from the AP, do they reconnect automatically, or do you need to connect them manually each time?

    To assist you further, could you please send us the diagnostic info of the AP via private message? Please follow the instructions in our FAQ on how to collect diagnostic info files for Standalone APs.

    If you are managing the AP via Nebula, please kindly enable Zyxel Support Access and provide us with the Org/Site name.

    Zyxel Nami

  • azimuthnrth
    Options

    When WPA3 is turned on, all Win 11 laptops are successfully connected end don't disconnect/reconnect. Win 10 disconnects and reconnects time after time. Win 10 reconnects after about 5 second again when it disconnected.

    The log says, the device is "disassociated" and deleted with "No error information" as it posted initially.

    UPD. It seems like, predominantly, disconnecting happens during some video streams.

  • Zyxel_Nami
    Zyxel_Nami Posts: 487  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @azimuthnrth

    What type of wireless adapters are your Windows 10 PCs using?

    To understand why disconnections occur at your site, we need more detailed information about your networking setup. Please provide the complete diagnostic file for a more in-depth analysis via a private message.

    Zyxel Nami

  • AlanM55
    AlanM55 Posts: 2
    Friend Collector First Comment
    Options

    They would automatically reconnect (unless configured to not automatically reconnect). Both laptops use the Intel AX201 chipset.

    Echoing what @azimuthnrth has been saying, the disconnects also seemed to happen when there was a lot of UDP traffic. My wife and typically have meetings in the afternoon around 1 which would cause an increase in UDP traffic.

    Following the hunch from @azimuthnrth, I changed the encryption over to WPA2 and I have yet to have another disconnect.

  • Zyxel_Nami
    Zyxel_Nami Posts: 487  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited April 19
    Options

    Hello both,

    To further investigate the issue, we kindly request your support in collecting diagnostic info files.

    Additionally, please provide us with the following information:

    @AlanM55

    Could you please check the driver version of the Intel AX201 by running the command "netsh wlan show driver" via Command Prompt on Windows?

    @azimuthnrth

    We understand your interest in using WPA3. To delve deeper into the issue, could you please provide the wireless card model and driver version that the affected devices are using?

    Besides Win10 and 11 devices, are there any other end devices encountering the same issue, such as mobile phones or 802.11ac models?

    Your assistance in providing this information will greatly aid us in resolving the issue effectively.

    Thank you

    Zyxel Nami