Low throughput through USG-60

Gantz75
Gantz75 Posts: 1
edited April 2021 in Security
Hi.

I have a new USG-60 with two NWA3123-AC connected.
My WAN is a 800-1200/100 Mbit connection.
Directly on the ISP modem I get between 750-950Mbits.
USG60 throughput is never more than 350Mbit over either cable and Wifi.
The configuration is basic "out of the box".




All Replies

  • PeterUK
    PeterUK Posts: 2,705  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer

    Thats the limit of the USG60 for TCP


  • Jeremylin
    Jeremylin Posts: 166  Master Member
    First Anniversary First Answer First Comment
    I do not think this is quit slow..  You can find in the datasheet throughput stats without any services active.  (1000 Mbps) I want to remind you that this is a lab test based on UDP packets.. As you know normal internet traffic is UDP and TCP traffic, this value is not actual what you will get on normal usage. Take 1/3 of this value and you will have an actual value to hold on to.. so 1000/3= 333 Mpbs.. That in my eyes is normal throughput for this device..
  • You are kidding? the 1gbps test is udp, but with tcp it will only perform at 1\3 of this speed? what a joke from ZyXEL...

  • Zyxel_Emily
    Zyxel_Emily Posts: 1,296  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Hi @MagnusBorgen,

    The maximum throughput 1000 Mbps for USG60 is measured based on UDP packets, not TCP.

    On the datasheet we have stated that the maximum throughput is measured based on RFC 2544 (1,518-byte UDP packets).

    If you run the speed on http://www.speedtest.net/, it runs over TCP.

    Here is the specification for your reference.

    https://www.zyxel.com/products_services/Unified-Security-Gateway-USG40-40W-60-60W/comparison#specifications

    Just like Jeremylin mentioned in the previous post, usually we take 1/2 of the UDP value for TCP throughput. The throughput may vary depending on the network traffic, so the actual measured TCP throughput is around 80% of 1/2 of UDP, which is 40% of UDP.

    In our lab test with 1G ISP connection, the Speed Test result for USG60 with firmware4.33 is as follows. (With default configuration file. Firewall and ADP are enabled.)

    Download speed is around 390-430 Mbps.



  • Raven
    Raven Posts: 2
    First Comment
    Hi Zyxel, is there anyway we can improve the internet speed ? Is UTM is enabled by default even we did not buy/activate the license ? Secondly, I saw other topic mention closing traffic statics will improve internet speed. Is that true ?
  • Raven
    Raven Posts: 2
    First Comment
    Zyxel, is that mean i get higher spec. I can guarantee to get more higher throughput, im looking for guarantee or nearly 1Gbps internet speed after go through USG with UTM & ADP enabled. So which spec of USG can do it ? USG 1100/1900/2200 ?

    User roughly about 500 users..
  • Zyxel_Jeff
    Zyxel_Jeff Posts: 1,063  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @Raven

    Welcome to join Zyxel community.

    You may refer to the following table for further evaluation.



    And further specifications you can refer to this link.
    Thanks.

  • ahfah
    ahfah Posts: 2
    First Comment
    Gantz75 said:
    Hi.

    I have a new USG-60 with two NWA3123-AC connected.
    My WAN is a 800-1200/100 Mbit connection.
    Directly on the ISP modem I get between 750-950Mbits.
    USG60 throughput is never more than 350Mbit over either cable and Wifi.
    The configuration is basic "out of the box".




    I have the same result as you, out of box around 350. and disable all features like SPI, AV, CSM...etc, I got about 520mbps. where my consumer level Asus RT-AC66U yields 920mpbs. While USG-60 is a possibly better protection, when enable some SPI and CSM functions, they drops to about 100mbps... well, if i read the USG-60 specification again, it only says 90mbps for UTM. (I guess with UTM, the TPUT is limited by all of the protective features.) Going to have to roll back and find alternatives.
  • ahfah
    ahfah Posts: 2
    First Comment

    Hi @Raven

    Welcome to join Zyxel community.

    You may refer to the following table for further evaluation.



    And further specifications you can refer to this link.
    Thanks.

    I love this response. Just installed the USG60 today. I have the similar issue as Gantz75 . I am surprised to see some discussion regarding UTP vs TCP connection...etc.
    I upgraded from an old Asus RT-AC66U. Expecting the USG60 to perform as specified. It is also funny that Zyxel_Jeff responded with a table showing USG1100 and above models, not the USG60. Which also should perform SPI Tput at 1.0GBPS. 
    I am talking about simply going to speedtest.net, run tput test. My RT-AC66U (from 2013) yields 920mbps down / 40mbps up. Where when I turn OFF EVERY POSSIBLE things on USG60, the best I can achieve is about 520mbps/35mbps. (This is turning off everything, no logging on sessions or interfaces, no firewall, no IDP, no AV, no CSM, nothing!) This is not about TCP or UDP, it is simply comparing routing TPUT without any bandwidth management nor protection. Once I start to enable some features on USG60, it starts to drop to 320mbps, and then 180mbps download speed. Simply not as advertised speed. Already plan to return the unit.

Security Highlight